summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrià Cereto-Massagué2018-03-09 08:28:43 +0100
committerAdrià Cereto-Massagué2018-03-09 08:28:43 +0100
commita161b0a6d93b4d5dd14c7f0e011da824bd98c3cd (patch)
tree5c100b4e8d30c428312892fdde034dfa3e78525d
parentc4253ec66b9280eb6a60e83e45d34d1b55fe9074 (diff)
downloadaur-a161b0a6d93b4d5dd14c7f0e011da824bd98c3cd.tar.gz
simplified PKGBUILD and slimmed down package by using upstream packaging script
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD35
2 files changed, 10 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9fc111cba5e2..2c93da366120 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dxvk-git
pkgdesc = A Vulkan-based compatibility layer for Direct3D 11 which allows running 3D applications on Linux using Wine. Requires Wine with Vulkan support (wine-vulkan)
- pkgver = 20180305.5f3bfde
+ pkgver = 20180308.e8303af
pkgrel = 1
url = https://github.com/doitsujin/dxvk
arch = x86_64
@@ -18,7 +18,7 @@ pkgbase = dxvk-git
options = !strip
options = !buildflags
options = staticlibs
- source = git+https://github.com/doitsujin/dxvk.git
+ source = dxvk-git::git+https://github.com/doitsujin/dxvk.git
md5sums = SKIP
pkgname = dxvk-git
diff --git a/PKGBUILD b/PKGBUILD
index 1539f9f1bb2b..cdb9a1ccebfa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,7 @@
# Maintainer: Adrià Cereto i Massagué <ssorgatem at gmail.com>
pkgname=dxvk-git
-_srcname=dxvk
-pkgver=20180305.5f3bfde
+pkgver=20180308.e8303af
pkgrel=1
epoch=
pkgdesc="A Vulkan-based compatibility layer for Direct3D 11 which allows running 3D applications on Linux using Wine. Requires Wine with Vulkan support (wine-vulkan)"
@@ -21,46 +20,28 @@ backup=()
options=(!strip !buildflags staticlibs)
install=
changelog=
-source=("git+https://github.com/doitsujin/dxvk.git")
+source=($pkgname::"git+https://github.com/doitsujin/dxvk.git")
noextract=()
md5sums=("SKIP")
validpgpkeys=()
pkgver() {
- cd "$_srcname"
+ cd "$pkgname"
git log -1 --format=%cd.%h --date=short|tr -d -
}
build() {
- cd "$_srcname"
- if [ -d "build.w64" ]; then rm -rf build.w64; fi
- meson --cross-file build-win64.txt build.w64
- cd build.w64
- meson configure -Dbuildtype=release
- ninja
- cd ..
- if [ -d "build.w32" ]; then rm -rf build.w32; fi
- meson --cross-file build-win32.txt build.w32
- cd build.w32
- meson configure -Dbuildtype=release
- ninja
+ "$pkgname"/package-release.sh git $PWD
}
package() {
- #Workaround meson bug that ignores prefix...
- mkdir -p "$pkgdir/usr/share/dxvk/x64"
- mkdir -p "$pkgdir/usr/share/dxvk/x32"
- cd "$_srcname"/build.w64
- DESTDIR="$pkgdir/" ninja install
- mv "$pkgdir/usr/local/"* "$pkgdir/usr/share/dxvk/x64"
- cd ../build.w32
- DESTDIR="$pkgdir/" ninja install
- mv "$pkgdir/usr/local/"* "$pkgdir/usr/share/dxvk/x32"
+ mkdir -p "$pkgdir/usr/share/dxvk"
+ tar -xf "$pkgname".tar.gz -C "$pkgdir/usr/share/dxvk" --strip-components=1
mkdir -p "$pkgdir/usr/bin"
- ln -s "/usr/share/dxvk/x32/bin/setup_dxvk.sh" "$pkgdir/usr/bin/setup_dxvk32"
- ln -s "/usr/share/dxvk/x64/bin/setup_dxvk.sh" "$pkgdir/usr/bin/setup_dxvk64"
+ ln -s "/usr/share/dxvk/x32/setup_dxvk.sh" "$pkgdir/usr/bin/setup_dxvk32"
+ ln -s "/usr/share/dxvk/x64/setup_dxvk.sh" "$pkgdir/usr/bin/setup_dxvk64"
}