summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrià Cereto-Massagué2022-08-23 22:53:11 +0200
committerAdrià Cereto-Massagué2022-08-23 22:53:11 +0200
commitbad568015a1d7dc1dfb4b33f5e01b5597c0aa213 (patch)
treeb8996eb124b90f2e0f75a3dfecac8cc56e26f77d
parent101043b0be0c6d87e6d3de24940ada05cf643bdd (diff)
downloadaur-bad568015a1d7dc1dfb4b33f5e01b5597c0aa213.tar.gz
fixed submodule handling
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD22
2 files changed, 16 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f4c466339768..d26ef00d4c1b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dxvk-git
pkgdesc = A Vulkan-based compatibility layer for Direct3D 9/10/11 which allows running 3D applications on Linux using Wine. Windows DLL version)
pkgver = 1.10.1.r695.g87b1f9fa
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/doitsujin/dxvk
arch = x86_64
license = zlib/libpng
@@ -31,9 +31,9 @@ pkgbase = dxvk-git
options = !buildflags
options = staticlibs
source = git+https://github.com/doitsujin/dxvk.git
- source = https://github.com/Joshua-Ashton/mingw-directx-headers
- source = https://github.com/KhronosGroup/Vulkan-Headers
- source = https://github.com/KhronosGroup/SPIRV-Headers.git
+ source = git+https://github.com/Joshua-Ashton/mingw-directx-headers.git
+ source = git+https://github.com/KhronosGroup/Vulkan-Headers.git
+ source = git+https://github.com/KhronosGroup/SPIRV-Headers.git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index aad0630268cc..b3bc2adb526d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgbase=dxvk-git
pkgname=('dxvk-mingw-git')
pkgver=1.10.1.r695.g87b1f9fa
-pkgrel=1
+pkgrel=2
pkgdesc="A Vulkan-based compatibility layer for Direct3D 9/10/11 which allows running 3D applications on Linux using Wine. Windows DLL version)"
arch=('x86_64')
url="https://github.com/doitsujin/dxvk"
@@ -13,10 +13,11 @@ provides=("dxvk" "d9vk" "dxvk=$pkgver")
makedepends=('ninja' 'meson>=0.43' 'glslang' 'mingw-w64-gcc' 'git' 'wine')
conflicts=('d9vk-mingw-git' 'd9vk-bin' 'd9vk-winelib-git' "dxvk-bin" "dxvk-git" "dxvk-wine32-git" "dxvk-wine64-git" "dxvk-win32-git" "dxvk-win64-git" "dxvk-winelib-git")
options=(!strip !buildflags staticlibs)
-source=("git+https://github.com/doitsujin/dxvk.git"
-"https://github.com/Joshua-Ashton/mingw-directx-headers"
-"https://github.com/KhronosGroup/Vulkan-Headers"
-"https://github.com/KhronosGroup/SPIRV-Headers.git"
+source=(
+ "git+https://github.com/doitsujin/dxvk.git"
+ "git+https://github.com/Joshua-Ashton/mingw-directx-headers.git"
+ "git+https://github.com/KhronosGroup/Vulkan-Headers.git"
+ "git+https://github.com/KhronosGroup/SPIRV-Headers.git"
)
sha256sums=("SKIP"
"SKIP"
@@ -31,11 +32,12 @@ pkgver() {
prepare() {
cd dxvk
- git submodule init
- git config submodule.mingw-directx-headers.url "$srcdir/include/native/directx"
- git config submodule.Vulkan-Headers.url "$srcdir/include/vulkan"
- git config submodule.SPIRV-Headers.git.url "$srcdir/include/spirv"
- git submodule update
+
+ git submodule init include/{native/directx,vulkan,spirv}
+ git config submodule.include/native/directx.url "$srcdir/mingw-directx-headers"
+ git config submodule.include/vulkan.url "$srcdir/Vulkan-Headers"
+ git config submodule.include/spirv.url "$srcdir/SPIRV-Headers"
+ git submodule update include/{native/directx,vulkan,spirv}
}
build() {