summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrià Cereto-Massagué2018-03-05 12:47:09 +0100
committerAdrià Cereto-Massagué2018-03-05 12:47:09 +0100
commitc4253ec66b9280eb6a60e83e45d34d1b55fe9074 (patch)
tree34e186edb4e3b5add01045fb3cfe33ed0f2dae76
parent2a065377b9cd337f1058995466ec3afcb303bc0f (diff)
downloadaur-c4253ec66b9280eb6a60e83e45d34d1b55fe9074.tar.gz
change installation directory and placement of setup scripts
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD22
2 files changed, 13 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 14839cb1f921..9fc111cba5e2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dxvk-git
- pkgdesc = A Vulkan-based compatibility layer for Direct3D 11 which allows running 3D applications on Linux using Wine. Requires Wine with Vulkan support (wine-staging or wine-vulkan)
- pkgver = 20180303.52f6ba1
+ pkgdesc = A Vulkan-based compatibility layer for Direct3D 11 which allows running 3D applications on Linux using Wine. Requires Wine with Vulkan support (wine-vulkan)
+ pkgver = 20180305.5f3bfde
pkgrel = 1
url = https://github.com/doitsujin/dxvk
arch = x86_64
@@ -12,6 +12,7 @@ pkgbase = dxvk-git
depends = vulkan-icd-loader
depends = wine
optdepends = wine-vulkan-git: Wine with Vulkan support
+ optdepends = wine-staging-vulkan-git: Wine with Vulkan support
provides = dxvk
conflicts = dxvk-bin
options = !strip
diff --git a/PKGBUILD b/PKGBUILD
index 3d4d615c2830..1539f9f1bb2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,10 @@
pkgname=dxvk-git
_srcname=dxvk
-pkgver=20180303.52f6ba1
+pkgver=20180305.5f3bfde
pkgrel=1
epoch=
-pkgdesc="A Vulkan-based compatibility layer for Direct3D 11 which allows running 3D applications on Linux using Wine. Requires Wine with Vulkan support (wine-staging or wine-vulkan)"
+pkgdesc="A Vulkan-based compatibility layer for Direct3D 11 which allows running 3D applications on Linux using Wine. Requires Wine with Vulkan support (wine-vulkan)"
arch=('x86_64')
url="https://github.com/doitsujin/dxvk"
license=('zlib/libpng')
@@ -13,7 +13,7 @@ groups=()
depends=('vulkan-icd-loader' 'wine')
makedepends=('ninja' 'meson' 'glslang' 'mingw-w64-gcc')
checkdepends=()
-optdepends=('wine-vulkan-git: Wine with Vulkan support')
+optdepends=('wine-vulkan-git: Wine with Vulkan support' 'wine-staging-vulkan-git: Wine with Vulkan support')
provides=("dxvk")
conflicts=("dxvk-bin")
replaces=()
@@ -52,17 +52,15 @@ build() {
package() {
#Workaround meson bug that ignores prefix...
- mkdir -p "$pkgdir/opt/dxvk/x64"
- mkdir -p "$pkgdir/opt/dxvk/x32"
+ mkdir -p "$pkgdir/usr/share/dxvk/x64"
+ mkdir -p "$pkgdir/usr/share/dxvk/x32"
cd "$_srcname"/build.w64
- #meson configure -Dprefix=/opt/dxvk/w64
DESTDIR="$pkgdir/" ninja install
- mv "$pkgdir/usr/local/"* "$pkgdir/opt/dxvk/x64"
+ mv "$pkgdir/usr/local/"* "$pkgdir/usr/share/dxvk/x64"
cd ../build.w32
- #meson configure -Dprefix=/opt/dxvk/w32
DESTDIR="$pkgdir/" ninja install
- mv "$pkgdir/usr/local/"* "$pkgdir/opt/dxvk/x32"
- mkdir -p "$pkgdir/usr/local/bin"
- ln -s "/opt/dxvk/x32/bin/setup_dxvk.sh" "$pkgdir/usr/local/bin/setup_dxvk32"
- ln -s "/opt/dxvk/x64/bin/setup_dxvk.sh" "$pkgdir/usr/local/bin/setup_dxvk64"
+ mv "$pkgdir/usr/local/"* "$pkgdir/usr/share/dxvk/x32"
+ mkdir -p "$pkgdir/usr/bin"
+ ln -s "/usr/share/dxvk/x32/bin/setup_dxvk.sh" "$pkgdir/usr/bin/setup_dxvk32"
+ ln -s "/usr/share/dxvk/x64/bin/setup_dxvk.sh" "$pkgdir/usr/bin/setup_dxvk64"
}