summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2023-11-18 15:26:43 +0200
committerStelios Tsampas2023-11-18 15:26:43 +0200
commit13c0d832efceb61f598f3459454c5d24174c12f1 (patch)
tree6dae27751c9257a15a20f6f40d530046b615f478
parentd470bdbd8fee2aad0b7757ac06edc09e652ed690 (diff)
downloadaur-13c0d832efceb61f598f3459454c5d24174c12f1.tar.gz
[dxvk-mingw(-git)] Remove async patch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
-rw-r--r--PKGBUILD.testing12
-rw-r--r--dxvk-async-conf.patch29
4 files changed, 0 insertions, 57 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a412f3b092b6..89032cff6ff8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -18,14 +18,10 @@ pkgbase = dxvk-mingw
options = !lto
options = !staticlibs
source = git+https://github.com/doitsujin/dxvk.git#tag=v2.3
- source = dxvk-async-2.2-3.patch::https://gitlab.com/Ph42oN/dxvk-gplasync/-/raw/main/patches/dxvk-gplasync-2.2-3.patch
- source = dxvk-async-conf.patch
source = dxvk-extraopts.patch
source = setup_dxvk.sh
source = setup_dxvk
sha256sums = SKIP
- sha256sums = 4b42ca101299b31ccb9c2099ccaa413076fa584c92d52ef6d4e05b024aec35c1
- sha256sums = c9c2f02bce1e1e93d511aff73484208456835d4d7601a36ab4524939472fc401
sha256sums = bcc15521e4c7f966a0192a1dabb7fb4935b33db39344ab5b861f9d81486f1362
sha256sums = 0f688815530ab5e8cc89b9b45d9b1d66cd8cd5a7770fb8249339af555a30dfe7
sha256sums = c1f6a18b03d1612b60f8081428f00cfac5e66315fe9d42719f01cf5564deeeff
diff --git a/PKGBUILD b/PKGBUILD
index f964bd4bca7a..ede36bc8ff54 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,6 @@
pkgname=dxvk-mingw
pkgver=2.3
-_asyncver=2.2-3
pkgrel=2
pkgdesc='Vulkan-based implementation of D3D9, D3D10 and D3D11 for Linux / Wine, MingW version'
arch=('x86_64')
@@ -14,8 +13,6 @@ conflicts=('dxvk' 'd9vk')
options=(!lto !staticlibs)
source=(
"git+https://github.com/doitsujin/dxvk.git#tag=v$pkgver"
- "dxvk-async-$_asyncver.patch::https://gitlab.com/Ph42oN/dxvk-gplasync/-/raw/main/patches/dxvk-gplasync-$_asyncver.patch"
- "dxvk-async-conf.patch"
"dxvk-extraopts.patch"
"setup_dxvk.sh"
"setup_dxvk"
@@ -75,13 +72,6 @@ prepare() {
-e "s|@CARGS@|\'${cross_cflags// /\',\'}\'|g" \
-e "s|@CXXARGS@|\'${cross_cxxflags// /\',\'}\'|g" \
-e "s|@LDARGS@|\'${cross_ldflags// /\',\'}\'|g"
-
- # Uncomment to enable dxvk async patch.
- # Enable at your own risk. If you don't know what it is,
- # and its implications, leave it as is. You have been warned.
- # I am not liable if anything happens to you by using it.
- #patch -p1 -i "$srcdir"/dxvk-async-${_asyncver}.patch
- #patch -p1 -i "$srcdir"/dxvk-async-conf.patch
}
build() {
@@ -115,8 +105,6 @@ package() {
}
sha256sums=('SKIP'
- '4b42ca101299b31ccb9c2099ccaa413076fa584c92d52ef6d4e05b024aec35c1'
- 'c9c2f02bce1e1e93d511aff73484208456835d4d7601a36ab4524939472fc401'
'bcc15521e4c7f966a0192a1dabb7fb4935b33db39344ab5b861f9d81486f1362'
'0f688815530ab5e8cc89b9b45d9b1d66cd8cd5a7770fb8249339af555a30dfe7'
'c1f6a18b03d1612b60f8081428f00cfac5e66315fe9d42719f01cf5564deeeff')
diff --git a/PKGBUILD.testing b/PKGBUILD.testing
index 9db6c112a754..5559df28ec92 100644
--- a/PKGBUILD.testing
+++ b/PKGBUILD.testing
@@ -2,7 +2,6 @@
pkgname=dxvk-mingw
pkgver=2.3
-_asyncver=2.2-3
pkgrel=2
pkgdesc='Vulkan-based implementation of D3D9, D3D10 and D3D11 for Linux / Wine, MingW version'
arch=('x86_64')
@@ -14,8 +13,6 @@ conflicts=('dxvk' 'd9vk')
options=(!lto !staticlibs)
source=(
"git+https://github.com/doitsujin/dxvk.git#tag=v$pkgver"
- "dxvk-async-$_asyncver.patch::https://gitlab.com/Ph42oN/dxvk-gplasync/-/raw/main/patches/dxvk-gplasync-$_asyncver.patch"
- "dxvk-async-conf.patch"
"dxvk-extraopts.patch"
"setup_dxvk.sh"
"setup_dxvk"
@@ -75,13 +72,6 @@ prepare() {
-e "s|@CARGS@|\'${cross_cflags// /\',\'}\'|g" \
-e "s|@CXXARGS@|\'${cross_cxxflags// /\',\'}\'|g" \
-e "s|@LDARGS@|\'${cross_ldflags// /\',\'}\'|g"
-
- # Uncomment to enable dxvk async patch.
- # Enable at your own risk. If you don't know what it is,
- # and its implications, leave it as is. You have been warned.
- # I am not liable if anything happens to you by using it.
- #patch -p1 -i "$srcdir"/dxvk-async-${_asyncver}.patch
- #patch -p1 -i "$srcdir"/dxvk-async-conf.patch
}
build() {
@@ -115,8 +105,6 @@ package() {
}
sha256sums=('SKIP'
- '4b42ca101299b31ccb9c2099ccaa413076fa584c92d52ef6d4e05b024aec35c1'
- 'c9c2f02bce1e1e93d511aff73484208456835d4d7601a36ab4524939472fc401'
'bcc15521e4c7f966a0192a1dabb7fb4935b33db39344ab5b861f9d81486f1362'
'0f688815530ab5e8cc89b9b45d9b1d66cd8cd5a7770fb8249339af555a30dfe7'
'c1f6a18b03d1612b60f8081428f00cfac5e66315fe9d42719f01cf5564deeeff')
diff --git a/dxvk-async-conf.patch b/dxvk-async-conf.patch
deleted file mode 100644
index 83b715546b6c..000000000000
--- a/dxvk-async-conf.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-diff --git a/dxvk.conf b/dxvk.conf
-index 9ca21a5e..abf0f2bf 100644
---- a/dxvk.conf
-+++ b/dxvk.conf
-@@ -214,6 +214,24 @@
- # dxvk.hud =
-
-
-+# Compile pipelines asynchronously if possible. This may reduce stuttering
-+# in some games, but may also introduce rendering issues that might become
-+# apparent over time. Do not report bugs with this option enabled.
-+#
-+# Supported values: True, False
-+
-+# dxvk.enableAsync = True
-+
-+
-+# Sets number of async compiler threads.
-+#
-+# Supported values:
-+# - 0 to automatically determine the number of threads to use
-+# - any positive number to enforce the thread count
-+
-+# dxvk.numAsyncThreads = 0
-+
-+
- # Reported shader model
- #
- # The shader model to state that we support in the device