summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2023-02-11 16:43:10 +0200
committerStelios Tsampas2023-02-11 16:43:10 +0200
commit2fc5cc8c65655e1957ad8b31b7a839e08d7bb975 (patch)
tree8336abfaaedf3f926c65c561afe167dd2a32db1e
parentedc22f914c9d35f9049ab5451e913e3367a24304 (diff)
downloadaur-2fc5cc8c65655e1957ad8b31b7a839e08d7bb975.tar.gz
[dxvk-mingw] use release tag for testing PKGBUILD
-rw-r--r--PKGBUILD.live4
-rw-r--r--PKGBUILD.testing13
2 files changed, 6 insertions, 11 deletions
diff --git a/PKGBUILD.live b/PKGBUILD.live
index 39e4538ab0e9..67e6e109d72c 100644
--- a/PKGBUILD.live
+++ b/PKGBUILD.live
@@ -52,8 +52,8 @@ prepare() {
# This overrides FLAGS from makepkg.conf, if you comment these you are on your own
# If you want the "best" possible optimizations for your system you can use
# `-march=native` and remove the `-mtune=core-avx2` option.
- export CFLAGS="-O2 -march=nocona -mtune=core-avx2 -pipe"
- export CXXFLAGS="-O2 -march=nocona -mtune=core-avx2 -pipe"
+ export CFLAGS="-O2 -march=haswell -mtune=haswell -pipe -fno-semantic-interposition"
+ export CXXFLAGS="-O2 -march=haswell -mtune=haswell -pipe -fno-semantic-interposition"
export LDFLAGS="-Wl,-O1,--sort-common,--as-needed"
# Uncomment to enable extra optimizations
diff --git a/PKGBUILD.testing b/PKGBUILD.testing
index f47c205a678a..1aa0f8c89ca1 100644
--- a/PKGBUILD.testing
+++ b/PKGBUILD.testing
@@ -1,8 +1,8 @@
# Maintainer: loathingkernel <loathingkernel @at gmail .dot com>
pkgname=dxvk-mingw
-pkgver=2.1.r0.g2abc102d
-_asyncver=master
+pkgver=2.1
+_asyncver=2.0
pkgrel=1
pkgdesc='Vulkan-based implementation of D3D9, D3D10 and D3D11 for Linux / Wine, MingW version'
arch=('x86_64')
@@ -14,7 +14,7 @@ provides=('dxvk' 'd9vk' "dxvk=$pkgver")
conflicts=('dxvk' 'd9vk')
options=(!lto !staticlibs)
source=(
- "git+https://github.com/doitsujin/dxvk.git"
+ "git+https://github.com/doitsujin/dxvk.git#tag=v$pkgver"
"git+https://github.com/KhronosGroup/Vulkan-Headers.git"
"git+https://github.com/KhronosGroup/SPIRV-Headers.git"
"git+https://gitlab.freedesktop.org/JoshuaAshton/libdisplay-info.git"
@@ -24,11 +24,6 @@ source=(
"setup_dxvk"
)
-pkgver() {
- cd dxvk
- printf "%s" "$(git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/v//g')"
-}
-
prepare() {
cd dxvk
@@ -128,7 +123,7 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP'
+ '85877b6ea801b3a139797628415ac5c74ec87ce16d1d3c434f5c36b00922833d'
'c9c2f02bce1e1e93d511aff73484208456835d4d7601a36ab4524939472fc401'
'bcc15521e4c7f966a0192a1dabb7fb4935b33db39344ab5b861f9d81486f1362'
'c1f6a18b03d1612b60f8081428f00cfac5e66315fe9d42719f01cf5564deeeff')