summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2024-01-25 17:53:17 +0200
committerStelios Tsampas2024-01-25 17:53:17 +0200
commit3854b705ba930b0e8ffb5a97ce081f0be3ff7946 (patch)
tree0fd5b4833c3b3051855376ae988726c88558d132
parent46ce08c73513b245ff169286c7407a61092d286f (diff)
downloadaur-3854b705ba930b0e8ffb5a97ce081f0be3ff7946.tar.gz
[dxvk,dxvk-nvapi,vkd3d-proton,d8vk] Update setup script
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--PKGBUILD.personal4
-rw-r--r--setup_dxvk.sh38
4 files changed, 24 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 89032cff6ff8..6a03b3aca071 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dxvk-mingw
pkgdesc = Vulkan-based implementation of D3D9, D3D10 and D3D11 for Linux / Wine, MingW version
pkgver = 2.3
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/doitsujin/dxvk
arch = x86_64
license = zlib/libpng
@@ -23,7 +23,7 @@ pkgbase = dxvk-mingw
source = setup_dxvk
sha256sums = SKIP
sha256sums = bcc15521e4c7f966a0192a1dabb7fb4935b33db39344ab5b861f9d81486f1362
- sha256sums = 0f688815530ab5e8cc89b9b45d9b1d66cd8cd5a7770fb8249339af555a30dfe7
+ sha256sums = e1d8623ea117be3d2537cc7f7465cae6e45d0309a502a0ed2b3bd9cd41e14e0e
sha256sums = c1f6a18b03d1612b60f8081428f00cfac5e66315fe9d42719f01cf5564deeeff
pkgname = dxvk-mingw
diff --git a/PKGBUILD b/PKGBUILD
index ede36bc8ff54..ca159e41c2e0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=dxvk-mingw
pkgver=2.3
-pkgrel=2
+pkgrel=3
pkgdesc='Vulkan-based implementation of D3D9, D3D10 and D3D11 for Linux / Wine, MingW version'
arch=('x86_64')
url="https://github.com/doitsujin/dxvk"
@@ -106,5 +106,5 @@ package() {
sha256sums=('SKIP'
'bcc15521e4c7f966a0192a1dabb7fb4935b33db39344ab5b861f9d81486f1362'
- '0f688815530ab5e8cc89b9b45d9b1d66cd8cd5a7770fb8249339af555a30dfe7'
+ 'e1d8623ea117be3d2537cc7f7465cae6e45d0309a502a0ed2b3bd9cd41e14e0e'
'c1f6a18b03d1612b60f8081428f00cfac5e66315fe9d42719f01cf5564deeeff')
diff --git a/PKGBUILD.personal b/PKGBUILD.personal
index 5559df28ec92..d9b100c145d8 100644
--- a/PKGBUILD.personal
+++ b/PKGBUILD.personal
@@ -2,7 +2,7 @@
pkgname=dxvk-mingw
pkgver=2.3
-pkgrel=2
+pkgrel=3
pkgdesc='Vulkan-based implementation of D3D9, D3D10 and D3D11 for Linux / Wine, MingW version'
arch=('x86_64')
url="https://github.com/doitsujin/dxvk"
@@ -106,5 +106,5 @@ package() {
sha256sums=('SKIP'
'bcc15521e4c7f966a0192a1dabb7fb4935b33db39344ab5b861f9d81486f1362'
- '0f688815530ab5e8cc89b9b45d9b1d66cd8cd5a7770fb8249339af555a30dfe7'
+ 'e1d8623ea117be3d2537cc7f7465cae6e45d0309a502a0ed2b3bd9cd41e14e0e'
'c1f6a18b03d1612b60f8081428f00cfac5e66315fe9d42719f01cf5564deeeff')
diff --git a/setup_dxvk.sh b/setup_dxvk.sh
index 0f1998f30d99..a45002f3c611 100644
--- a/setup_dxvk.sh
+++ b/setup_dxvk.sh
@@ -68,21 +68,24 @@ if ! [ -f "$wine_path/$wine" ]; then
fi
# resolve 32-bit and 64-bit system32 path
-winever=$($wine --version | grep wine)
+winever="$($wine --version | grep wine)"
if [ -z "$winever" ]; then
- echo "$wine:"' Not a wine executable. Check your $wine.' >&2
- exit 1
+ echo "$wine:"' Not a wine executable. Check your $wine.' >&2
+ exit 1
fi
# ensure wine placeholder dlls are recreated
# if they are missing
$wineboot -u
-win64_sys_path=$($wine64 winepath -u 'C:\windows\system32' 2> /dev/null)
+win64_sys_path=$($wine winepath -u 'C:\windows\system32' 2> /dev/null)
win64_sys_path="${win64_sys_path/$'\r'/}"
-if $wow64; then
- win32_sys_path=$($wine winepath -u 'C:\windows\system32' 2> /dev/null)
- win32_sys_path="${win32_sys_path/$'\r'/}"
+win32_sys_path=$($wine winepath -u 'C:\windows\syswow64' 2> /dev/null)
+win32_sys_path="${win32_sys_path/$'\r'/}"
+
+# if syswow64 for the prefix doesn't exist, treat it as a win32 prefix
+if ! [ -d "$win32_sys_path" ]; then
+ win32_sys_path="$win64_sys_path"
fi
if [ -z "$win32_sys_path" ] && [ -z "$win64_sys_path" ]; then
@@ -92,7 +95,7 @@ fi
# create native dll override
overrideDll() {
- $wine reg add 'HKEY_CURRENT_USER\Software\Wine\DllOverrides' /v $1 /d native /f >/dev/null 2>&1
+ $wine reg add 'HKEY_CURRENT_USER\Software\Wine\DllOverrides' /v "$1" /d native /f >/dev/null 2>&1
if [ $? -ne 0 ]; then
echo -e "Failed to add override for $1"
exit 1
@@ -101,7 +104,7 @@ overrideDll() {
# remove dll override
restoreDll() {
- $wine reg delete 'HKEY_CURRENT_USER\Software\Wine\DllOverrides' /v $1 /f > /dev/null 2>&1
+ $wine reg delete 'HKEY_CURRENT_USER\Software\Wine\DllOverrides' /v "$1" /f > /dev/null 2>&1
if [ $? -ne 0 ]; then
echo "Failed to remove override for $1"
fi
@@ -112,10 +115,6 @@ installFile() {
dstfile="${1}/${3}.dll"
srcfile="${basedir}/${2}/${3}.dll"
- if [ -f "${srcfile}.so" ]; then
- srcfile="${srcfile}.so"
- fi
-
if ! [ -f "${srcfile}" ]; then
echo "${srcfile}: File not found. Skipping." >&2
return 1
@@ -128,11 +127,10 @@ installFile() {
else
rm -v "${dstfile}"
fi
- $file_cmd "${srcfile}" "${dstfile}"
else
- echo "${dstfile}: File not found in wine prefix" >&2
- return 1
+ touch "${dstfile}.old_none"
fi
+ $file_cmd "${srcfile}" "${dstfile}"
fi
return 0
}
@@ -142,10 +140,6 @@ uninstallFile() {
dstfile="${1}/${3}.dll"
srcfile="${basedir}/${2}/${3}.dll"
- if [ -f "${srcfile}.so" ]; then
- srcfile="${srcfile}.so"
- fi
-
if ! [ -f "${srcfile}" ]; then
echo "${srcfile}: File not found. Skipping." >&2
return 1
@@ -160,6 +154,10 @@ uninstallFile() {
rm -v "${dstfile}"
mv -v "${dstfile}.old" "${dstfile}"
return 0
+ elif [ -f "${dstfile}.old_none" ]; then
+ rm -v "${dstfile}.old_none"
+ rm -v "${dstfile}"
+ return 0
else
return 1
fi