summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2022-12-20 20:03:54 +0200
committerStelios Tsampas2022-12-20 20:03:54 +0200
commit39864477bedd09d21f7fc1fe8f3a02ad238a90a1 (patch)
treeae9c6fa0f3533f831c1100ddc845ae619fa3d642
parentfe6ec8e183154d60e83a045ee7452250bd59ec8a (diff)
downloadaur-39864477bedd09d21f7fc1fe8f3a02ad238a90a1.tar.gz
[dxvk-mingw] Reference dxvk-async tag
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--PKGBUILD.live10
-rw-r--r--PKGBUILD.testing12
4 files changed, 19 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f32157fbf179..9b45fa162b51 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -23,7 +23,7 @@ pkgbase = dxvk-mingw
source = git+https://github.com/doitsujin/dxvk.git#tag=v2.0
source = git+https://github.com/KhronosGroup/Vulkan-Headers.git
source = git+https://github.com/KhronosGroup/SPIRV-Headers.git
- source = dxvk-async-8665e60.patch::https://raw.githubusercontent.com/Sporif/dxvk-async/8665e60/dxvk-async.patch
+ source = dxvk-async-2.0.patch::https://raw.githubusercontent.com/Sporif/dxvk-async/2.0/dxvk-async.patch
source = dxvk-async-conf.patch
source = dxvk-extraopts.patch
source = setup_dxvk
diff --git a/PKGBUILD b/PKGBUILD
index 3c4ca685c156..f09546733149 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=dxvk-mingw
pkgver=2.0
-_asyncver=8665e60
+_asyncver=2.0
pkgrel=1
pkgdesc='Vulkan-based implementation of D3D9, D3D10 and D3D11 for Linux / Wine, MingW version'
arch=('x86_64')
diff --git a/PKGBUILD.live b/PKGBUILD.live
index 14c79ea65d33..39e4538ab0e9 100644
--- a/PKGBUILD.live
+++ b/PKGBUILD.live
@@ -17,6 +17,7 @@ source=(
"git+https://github.com/doitsujin/dxvk.git"
"git+https://github.com/KhronosGroup/Vulkan-Headers.git"
"git+https://github.com/KhronosGroup/SPIRV-Headers.git"
+ "git+https://gitlab.freedesktop.org/JoshuaAshton/libdisplay-info.git"
"dxvk-async-${_asyncver}.patch::https://raw.githubusercontent.com/Sporif/dxvk-async/${_asyncver}/dxvk-async.patch"
"dxvk-async-conf.patch"
"dxvk-extraopts.patch"
@@ -31,10 +32,14 @@ pkgver() {
prepare() {
cd dxvk
- git submodule init include/{vulkan,spirv}
+ git revert -n 7644776f7a3bc6a097f20c1465708acf88ad215f
+ git revert -n 64cb1ad208f80b11400eef779e99fec223754098
+
+ git submodule init include/{vulkan,spirv} subprojects/libdisplay-info
git submodule set-url include/vulkan "$srcdir/Vulkan-Headers"
git submodule set-url include/spirv "$srcdir/SPIRV-Headers"
- git -c protocol.file.allow=always submodule update include/{vulkan,spirv}
+ git submodule set-url subprojects/libdisplay-info "$srcdir/libdisplay-info"
+ git -c protocol.file.allow=always submodule update include/{vulkan,spirv} subprojects/libdisplay-info
# Uncomment to enable dxvk async patch.
# Enable at your own risk. If you don't know what it is,
@@ -123,6 +128,7 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'c9c2f02bce1e1e93d511aff73484208456835d4d7601a36ab4524939472fc401'
'bcc15521e4c7f966a0192a1dabb7fb4935b33db39344ab5b861f9d81486f1362'
'c1f6a18b03d1612b60f8081428f00cfac5e66315fe9d42719f01cf5564deeeff')
diff --git a/PKGBUILD.testing b/PKGBUILD.testing
index 83b898ce49b1..ee624cd8c3e5 100644
--- a/PKGBUILD.testing
+++ b/PKGBUILD.testing
@@ -1,7 +1,7 @@
# Maintainer: loathingkernel <loathingkernel @at gmail .dot com>
pkgname=dxvk-mingw
-pkgver=2.0.r0.g8f8a9369
+pkgver=2.0.r45.g12901b52
_asyncver=master
pkgrel=1
pkgdesc='Vulkan-based implementation of D3D9, D3D10 and D3D11 for Linux / Wine, MingW version'
@@ -17,6 +17,7 @@ source=(
"git+https://github.com/doitsujin/dxvk.git"
"git+https://github.com/KhronosGroup/Vulkan-Headers.git"
"git+https://github.com/KhronosGroup/SPIRV-Headers.git"
+ "git+https://gitlab.freedesktop.org/JoshuaAshton/libdisplay-info.git"
"dxvk-async-${_asyncver}.patch::https://raw.githubusercontent.com/Sporif/dxvk-async/${_asyncver}/dxvk-async.patch"
"dxvk-async-conf.patch"
"dxvk-extraopts.patch"
@@ -31,10 +32,14 @@ pkgver() {
prepare() {
cd dxvk
- git submodule init include/{vulkan,spirv}
+ git revert -n 7644776f7a3bc6a097f20c1465708acf88ad215f
+ git revert -n 64cb1ad208f80b11400eef779e99fec223754098
+
+ git submodule init include/{vulkan,spirv} subprojects/libdisplay-info
git submodule set-url include/vulkan "$srcdir/Vulkan-Headers"
git submodule set-url include/spirv "$srcdir/SPIRV-Headers"
- git -c protocol.file.allow=always submodule update include/{vulkan,spirv}
+ git submodule set-url subprojects/libdisplay-info "$srcdir/libdisplay-info"
+ git -c protocol.file.allow=always submodule update include/{vulkan,spirv} subprojects/libdisplay-info
# Uncomment to enable dxvk async patch.
# Enable at your own risk. If you don't know what it is,
@@ -123,6 +128,7 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'c9c2f02bce1e1e93d511aff73484208456835d4d7601a36ab4524939472fc401'
'bcc15521e4c7f966a0192a1dabb7fb4935b33db39344ab5b861f9d81486f1362'
'c1f6a18b03d1612b60f8081428f00cfac5e66315fe9d42719f01cf5564deeeff')