summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2022-03-05 11:39:10 +0200
committerStelios Tsampas2022-03-05 11:39:10 +0200
commitb7249fd3437b0d89cd46f0e3c2f71465e45d86be (patch)
tree9a4c6443e8f8f8fe93da97f817cbefd9d1439c2d
parentd8e7c0c1fa70e1500e35384de54df402a28f0290 (diff)
downloadaur-b7249fd3437b0d89cd46f0e3c2f71465e45d86be.tar.gz
Version 1.10
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD19
2 files changed, 14 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef2d6d69803b..1c49c381260f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dxvk-mingw
pkgdesc = Vulkan-based implementation of D3D9, D3D10 and D3D11 for Linux / Wine, MingW version
- pkgver = 1.9.4
+ pkgver = 1.10
pkgrel = 1
url = https://github.com/doitsujin/dxvk
arch = x86_64
@@ -15,18 +15,18 @@ pkgbase = dxvk-mingw
depends = bash
provides = dxvk
provides = d9vk
- provides = dxvk=1.9.4
+ provides = dxvk=1.10
conflicts = dxvk
conflicts = d9vk
options = !lto
options = !staticlibs
- source = git+https://github.com/doitsujin/dxvk.git#tag=v1.9.4
- source = dxvk-async-1.9.3.patch::https://raw.githubusercontent.com/Sporif/dxvk-async/1.9.3/dxvk-async.patch
+ source = git+https://github.com/doitsujin/dxvk.git#tag=v1.10
+ source = dxvk-async-1.10.patch::https://raw.githubusercontent.com/Sporif/dxvk-async/1.10/dxvk-async.patch
source = dxvk-async-conf.patch
source = dxvk-extraopts.patch
source = setup_dxvk
sha256sums = SKIP
- sha256sums = ddde07c98045a3bc15fab5eaf3c6a756a6a4b4eaeec646d4339168b86ac00463
+ sha256sums = e6f042cdfd1d20d3bad0e5732696d453efde0502beacc3788e2af3568eeacd68
sha256sums = c9c2f02bce1e1e93d511aff73484208456835d4d7601a36ab4524939472fc401
sha256sums = bcc15521e4c7f966a0192a1dabb7fb4935b33db39344ab5b861f9d81486f1362
sha256sums = b2413cabd8cca56e2d308ef5513edf1c7f909036ed2ccfeae17536a0e864dc96
diff --git a/PKGBUILD b/PKGBUILD
index cc8e76c69f0e..25644099cf83 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: loathingkernel <loathingkernel @at gmail .dot com>
pkgname=dxvk-mingw
-pkgver=1.9.4
-_asyncver=1.9.3
+pkgver=1.10
+_asyncver=1.10
pkgrel=1
pkgdesc='Vulkan-based implementation of D3D9, D3D10 and D3D11 for Linux / Wine, MingW version'
arch=('x86_64')
@@ -49,8 +49,8 @@ prepare() {
# If you want the "best" possible optimizations for your system you can use
# `-march=native` and remove the `-mtune=core-avx2` option.
# `-O2` is adjusted to `-O3` since AVX is disabled
- export CFLAGS="-O3 -march=nocona -pipe -mtune=core-avx2"
- export CXXFLAGS="-O3 -march=nocona -pipe -mtune=core-avx2"
+ export CFLAGS="-O3 -march=nocona -mtune=core-avx2 -pipe"
+ export CXXFLAGS="-O3 -march=nocona -mtune=core-avx2 -pipe"
export LDFLAGS="-Wl,-O1,--sort-common,--as-needed"
# Uncomment to enable extra optimizations
@@ -72,8 +72,8 @@ prepare() {
# Relevant Wine issues
# https://bugs.winehq.org/show_bug.cgi?id=45289
# https://bugs.winehq.org/show_bug.cgi?id=43516
- cross_cflags+=" -mno-avx -mno-avx2"
- cross_cxxflags+=" -mno-avx -mno-avx2"
+ cross_cflags+=" -mno-avx2"
+ cross_cxxflags+=" -mno-avx2"
# These flags are taken from Proton, I don't know if there are issues with Arch wine.
cross_cflags+=" -mfpmath=sse -fwrapv -fno-strict-aliasing -gdwarf-2 -gstrict-dwarf"
@@ -85,8 +85,8 @@ prepare() {
-e "s|@CXXARGS@|\'${cross_cxxflags// /\',\'}\'|g" \
-e "s|@LDARGS@|\'${cross_ldflags// /\',\'}\'|g"
- cross_cflags+=" -mstackrealign"
- cross_cxxflags+=" -mstackrealign"
+ cross_cflags+=" -mstackrealign -mno-avx"
+ cross_cxxflags+=" -mstackrealign -mno-avx"
sed -i build-win32.txt \
-e "s|@CARGS@|\'${cross_cflags// /\',\'}\'|g" \
-e "s|@CXXARGS@|\'${cross_cxxflags// /\',\'}\'|g" \
@@ -123,8 +123,7 @@ package() {
}
sha256sums=('SKIP'
- 'ddde07c98045a3bc15fab5eaf3c6a756a6a4b4eaeec646d4339168b86ac00463'
+ 'e6f042cdfd1d20d3bad0e5732696d453efde0502beacc3788e2af3568eeacd68'
'c9c2f02bce1e1e93d511aff73484208456835d4d7601a36ab4524939472fc401'
'bcc15521e4c7f966a0192a1dabb7fb4935b33db39344ab5b861f9d81486f1362'
'b2413cabd8cca56e2d308ef5513edf1c7f909036ed2ccfeae17536a0e864dc96')
-