summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2023-03-24 19:25:24 +0200
committerStelios Tsampas2023-03-24 19:25:24 +0200
commitf8c625903994f66a10224c4986c1727cebbd8247 (patch)
treeed346eec54a697c4423c80ee5f000c7b394a8dd9
parent2fa066e628176141893f55fd3a54e731e8b3f4c3 (diff)
downloadaur-f8c625903994f66a10224c4986c1727cebbd8247.tar.gz
[meta] switch to -O2
-rw-r--r--PKGBUILD.testing4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD.testing b/PKGBUILD.testing
index 093dfcd77f36..40a312dc3cd9 100644
--- a/PKGBUILD.testing
+++ b/PKGBUILD.testing
@@ -45,8 +45,8 @@ prepare() {
# This overrides FLAGS from makepkg.conf, if you comment these you are on your own
# If you want the "best" possible optimizations for your system you can use
# `-march=native` and remove the `-mtune=core-avx2` option.
- export CFLAGS="-O3 -march=haswell -mtune=haswell -pipe -fno-semantic-interposition"
- export CXXFLAGS="-O3 -march=haswell -mtune=haswell -pipe -fno-semantic-interposition"
+ export CFLAGS="-O2 -march=haswell -mtune=haswell -pipe -fno-semantic-interposition"
+ export CXXFLAGS="-O2 -march=haswell -mtune=haswell -pipe -fno-semantic-interposition"
export LDFLAGS="-Wl,-O1,--sort-common,--as-needed"
# Uncomment to enable extra optimizations