summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2024-01-25 17:53:17 +0200
committerStelios Tsampas2024-01-25 17:53:17 +0200
commit4385469234d8b7ba9c8d2a240c99baa0b095a313 (patch)
tree906903d50833e74192fc767d2af470d47cb3ecd6
parentfcac8fefb30d9b38144ae109b304e4a8d44726a8 (diff)
downloadaur-4385469234d8b7ba9c8d2a240c99baa0b095a313.tar.gz
[dxvk,dxvk-nvapi,vkd3d-proton,d8vk] Update setup script
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--PKGBUILD.personal7
-rwxr-xr-xsetup_dxvk_nvapi.sh31
4 files changed, 20 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 194aa7108de4..3aa9b738ac45 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -20,7 +20,7 @@ pkgbase = dxvk-nvapi-mingw-git
source = setup_dxvk_nvapi
sha256sums = SKIP
sha256sums = dff5ecd1a35a94a4dc1fa5fd08c10b5c88703797520d6b315207124ff1adeef8
- sha256sums = 62a14512ab32ff534d8b07f2cdefae17ee679c73465edeb11bfac1e88f0a7109
+ sha256sums = b40b67bdc1bbe9bf103737824c53e1f7dcbaa78345e8df5b767bd72bff7c78c4
sha256sums = 1f4934c5bfcf208e288a0eda2f385f82acc9e78a4b0ac2a77b5af14c64c8e21e
pkgname = dxvk-nvapi-mingw-git
diff --git a/PKGBUILD b/PKGBUILD
index 5e9fbeb11f26..2ea6e290319b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -112,5 +112,5 @@ package() {
sha256sums=('SKIP'
'dff5ecd1a35a94a4dc1fa5fd08c10b5c88703797520d6b315207124ff1adeef8'
- '62a14512ab32ff534d8b07f2cdefae17ee679c73465edeb11bfac1e88f0a7109'
+ 'b40b67bdc1bbe9bf103737824c53e1f7dcbaa78345e8df5b767bd72bff7c78c4'
'1f4934c5bfcf208e288a0eda2f385f82acc9e78a4b0ac2a77b5af14c64c8e21e')
diff --git a/PKGBUILD.personal b/PKGBUILD.personal
index 83df3ad7a137..b3ceb600daff 100644
--- a/PKGBUILD.personal
+++ b/PKGBUILD.personal
@@ -17,9 +17,6 @@ source=(
"setup_dxvk_nvapi.sh"
"setup_dxvk_nvapi"
)
-#Optional patches
-source+=(
-)
pkgver() {
cd dxvk-nvapi
@@ -115,7 +112,5 @@ package() {
sha256sums=('SKIP'
'dff5ecd1a35a94a4dc1fa5fd08c10b5c88703797520d6b315207124ff1adeef8'
- '62a14512ab32ff534d8b07f2cdefae17ee679c73465edeb11bfac1e88f0a7109'
+ 'b40b67bdc1bbe9bf103737824c53e1f7dcbaa78345e8df5b767bd72bff7c78c4'
'1f4934c5bfcf208e288a0eda2f385f82acc9e78a4b0ac2a77b5af14c64c8e21e')
-sha256sums+=(
-)
diff --git a/setup_dxvk_nvapi.sh b/setup_dxvk_nvapi.sh
index 8a5c60c4ecb5..aa4e8a8e40f3 100755
--- a/setup_dxvk_nvapi.sh
+++ b/setup_dxvk_nvapi.sh
@@ -5,7 +5,7 @@ dxvk_nvapi_lib32=${dxvk_nvapi_lib32:-"x32"}
dxvk_nvapi_lib64=${dxvk_nvapi_lib64:-"x64"}
# figure out where we are
-basedir=$(dirname "$(readlink -f "$0")")
+basedir="$(dirname "$(readlink -f "$0")")"
# figure out which action to perform
action="$1"
@@ -24,7 +24,7 @@ esac
# process arguments
shift
-file_cmd="cp -v"
+file_cmd="cp -v --reflink=auto"
while (($# > 0)); do
case "$1" in
@@ -64,21 +64,24 @@ if ! [ -f "$wine_path/$wine" ]; then
fi
# resolve 32-bit and 64-bit system32 path
-winever=$($wine --version | grep wine)
+winever="$($wine --version | grep wine)"
if [ -z "$winever" ]; then
- echo "$wine: Not a wine executable. Check your $wine." >&2
- exit 1
+ echo "$wine:"' Not a wine executable. Check your $wine.' >&2
+ exit 1
fi
# ensure wine placeholder dlls are recreated
# if they are missing
$wineboot -u
-win64_sys_path=$($wine64 winepath -u 'C:\windows\system32' 2> /dev/null)
+win64_sys_path=$($wine winepath -u 'C:\windows\system32' 2> /dev/null)
win64_sys_path="${win64_sys_path/$'\r'/}"
-if $wow64; then
- win32_sys_path=$($wine winepath -u 'C:\windows\system32' 2> /dev/null)
- win32_sys_path="${win32_sys_path/$'\r'/}"
+win32_sys_path=$($wine winepath -u 'C:\windows\syswow64' 2> /dev/null)
+win32_sys_path="${win32_sys_path/$'\r'/}"
+
+# if syswow64 for the prefix doesn't exist, treat it as a win32 prefix
+if ! [ -d "$win32_sys_path" ]; then
+ win32_sys_path="$win64_sys_path"
fi
if [ -z "$win32_sys_path" ] && [ -z "$win64_sys_path" ]; then
@@ -88,8 +91,8 @@ fi
# create native dll override
overrideDll() {
- if ! $wine reg add 'HKEY_CURRENT_USER\Software\Wine\DllOverrides' /v "$1" /d native /f >/dev/null 2>&1
- then
+ $wine reg add 'HKEY_CURRENT_USER\Software\Wine\DllOverrides' /v "$1" /d native /f >/dev/null 2>&1
+ if [ $? -ne 0 ]; then
echo -e "Failed to add override for $1"
exit 1
fi
@@ -97,8 +100,8 @@ overrideDll() {
# remove dll override
restoreDll() {
- if ! $wine reg delete 'HKEY_CURRENT_USER\Software\Wine\DllOverrides' /v "$1" /f > /dev/null 2>&1
- then
+ $wine reg delete 'HKEY_CURRENT_USER\Software\Wine\DllOverrides' /v "$1" /f > /dev/null 2>&1
+ if [ $? -ne 0 ]; then
echo "Failed to remove override for $1"
fi
}
@@ -179,7 +182,7 @@ uninstall() {
if (( (uninst64_ret == 0) )); then
restoreDll "${1}64"
fi
-
+
uninst32_ret=-1
if $wow64; then
uninstallFile "$win32_sys_path" "$dxvk_nvapi_lib32" "$1"