summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2024-01-25 21:50:39 +0200
committerStelios Tsampas2024-01-25 21:50:39 +0200
commit718f963a47e2c9708270a49005adcd544af8e22c (patch)
treedd04e8e44573124a73c733723c89def3b8207153
parentc1f230ce201a3f4c4aadc35daeb9131849976091 (diff)
downloadaur-718f963a47e2c9708270a49005adcd544af8e22c.tar.gz
[dxvk-nvapi-mingw] Fix compiler flags
-rw-r--r--PKGBUILD4
-rw-r--r--PKGBUILD.personal4
-rw-r--r--[-rwxr-xr-x]setup_dxvk_nvapi.sh0
3 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 190189a2d329..1d174279cd91 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -45,8 +45,8 @@ prepare() {
local march="${flags["-march"]:-nocona}"
local mtune="${flags["-mtune"]:-core-avx2}"
- export CFLAGS="-O2 -march="$_march" -mtune="$_mtune" -pipe"
- export CXXFLAGS="-O2 -march="$_march" -mtune="$_mtune" -pipe"
+ export CFLAGS="-O2 -march="$march" -mtune="$mtune" -pipe"
+ export CXXFLAGS="-O2 -march="$march" -mtune="$mtune" -pipe"
export LDFLAGS="-Wl,-O1,--sort-common,--as-needed"
# These flags are taken from Proton
diff --git a/PKGBUILD.personal b/PKGBUILD.personal
index 190189a2d329..1d174279cd91 100644
--- a/PKGBUILD.personal
+++ b/PKGBUILD.personal
@@ -45,8 +45,8 @@ prepare() {
local march="${flags["-march"]:-nocona}"
local mtune="${flags["-mtune"]:-core-avx2}"
- export CFLAGS="-O2 -march="$_march" -mtune="$_mtune" -pipe"
- export CXXFLAGS="-O2 -march="$_march" -mtune="$_mtune" -pipe"
+ export CFLAGS="-O2 -march="$march" -mtune="$mtune" -pipe"
+ export CXXFLAGS="-O2 -march="$march" -mtune="$mtune" -pipe"
export LDFLAGS="-Wl,-O1,--sort-common,--as-needed"
# These flags are taken from Proton
diff --git a/setup_dxvk_nvapi.sh b/setup_dxvk_nvapi.sh
index aa4e8a8e40f3..aa4e8a8e40f3 100755..100644
--- a/setup_dxvk_nvapi.sh
+++ b/setup_dxvk_nvapi.sh