summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2024-01-27 04:03:43 +0200
committerStelios Tsampas2024-01-27 04:03:43 +0200
commit79de75d6f24489e8a29ffc0cad3d805d9a33b404 (patch)
tree17e5b70c1f4370a3439677a0b3f36aae76e11d00
parent03d0b2cc3dd05e987b765a87f596797d2e3288cb (diff)
downloadaur-79de75d6f24489e8a29ffc0cad3d805d9a33b404.tar.gz
[dxvk-nvapi-mingw-git] Revert to no-avx
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3aa9b738ac45..7c176963f72b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dxvk-nvapi-mingw-git
pkgdesc = Alternative NVAPI implementation on top of DXVK
- pkgver = 0.6.4.r16.g03cc59d
+ pkgver = 0.6.4.r48.g0951afb
pkgrel = 1
url = https://github.com/jp7677/dxvk-nvapi
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index a44b23fb6c45..c2e92d02c858 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: loathingkernel <loathingkernel @at gmail .dot com>
pkgname=dxvk-nvapi-mingw-git
-pkgver=0.6.4.r16.g03cc59d
+pkgver=0.6.4.r48.g0951afb
pkgrel=1
pkgdesc='Alternative NVAPI implementation on top of DXVK'
arch=('x86_64')
@@ -39,9 +39,9 @@ prepare() {
# If you want the "best" possible optimizations for your system you can use
# `-march=native` and remove the `-mtune=core-avx2` option.
-# local -a split=($CFLAGS)
-# local -A flags
-# for opt in "${split[@]}"; do flags["${opt%%=*}"]="${opt##*=}"; done
+ local -a split=($CFLAGS)
+ local -A flags
+ for opt in "${split[@]}"; do flags["${opt%%=*}"]="${opt##*=}"; done
local march="${flags["-march"]:-nocona}"
local mtune="${flags["-mtune"]:-core-avx2}"
@@ -66,8 +66,8 @@ prepare() {
# Relevant Wine issues
# https://bugs.winehq.org/show_bug.cgi?id=45289
# https://bugs.winehq.org/show_bug.cgi?id=43516
- CFLAGS+=" -mno-avx2"
- CXXFLAGS+=" -mno-avx2"
+ CFLAGS+=" -mno-avx2 -mno-avx"
+ CXXFLAGS+=" -mno-avx2 -mno-avx"
local cross_ldflags="$LDFLAGS"