summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilipe Laíns2019-12-04 10:19:03 +0000
committerFilipe Laíns2019-12-04 10:19:03 +0000
commit4efca9c085b5471ef3f7dd81c908831a7ddbfa9b (patch)
treeac2e5088ca3d90a100c75f225817fc2e9374ccb0
parente1368264a70e248646643263d3fce6f84b960001 (diff)
downloadaur-4efca9c085b5471ef3f7dd81c908831a7ddbfa9b.tar.gz
don't automatically fetch the latest tag
Signed-off-by: Filipe Laíns <lains@archlinux.org>
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
2 files changed, 5 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dd7011e6da21..816dee16f78e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dxvk-winelib
- pkgdesc = A Vulkan-based compatibility layer for Direct3D 10/11 which allows running 3D applications on Linux using Wine. Winelib version. Auto gets latest tag!
+ pkgdesc = A Vulkan-based compatibility layer for Direct3D 10/11 which allows running 3D applications on Linux using Wine. Winelib version.
pkgver = 1.4.4
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/doitsujin/dxvk
arch = x86_64
license = zlib/libpng
@@ -29,7 +29,7 @@ pkgbase = dxvk-winelib
conflicts = dxvk-win64-git
conflicts = dxvk-winelib-git
conflicts = dxvk
- source = git+https://github.com/doitsujin/dxvk.git
+ source = git+https://github.com/doitsujin/dxvk.git#tag=1.4.4
sha256sums = SKIP
pkgname = dxvk-winelib
diff --git a/PKGBUILD b/PKGBUILD
index 64572d9c7c1e..72f445aa7e7f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgbase=dxvk-winelib
pkgname=dxvk-winelib
pkgver=1.4.4
pkgrel=2
-pkgdesc="A Vulkan-based compatibility layer for Direct3D 10/11 which allows running 3D applications on Linux using Wine. Winelib version. Auto gets latest tag!"
+pkgdesc="A Vulkan-based compatibility layer for Direct3D 10/11 which allows running 3D applications on Linux using Wine. Winelib version."
arch=('x86_64')
url="https://github.com/doitsujin/dxvk"
license=('zlib/libpng')
@@ -14,21 +14,9 @@ makedepends=('ninja' 'meson' 'glslang' 'git' 'wine')
provides=("dxvk-bin" "dxvk-git" "dxvk-wine32-git" "dxvk-wine64-git" "dxvk-win32-git" "dxvk-win64-git" "dxvk-mingw-git" "dxvk-winelib-git" "dxvk")
conflicts=("dxvk-git" "dxvk-wine32-git" "dxvk-wine64-git" "dxvk-win32-git" "dxvk-win64-git" "dxvk-winelib-git" "dxvk")
-source=("git+https://github.com/doitsujin/dxvk.git")
+source=("git+https://github.com/doitsujin/dxvk.git#tag=$pkgver")
sha256sums=("SKIP")
-prepare() {
- cd dxvk
- git fetch --tags
- a=`git tag | tail -n1`
- git checkout $a
-}
-
-pkgver() {
- cd dxvk
- git tag | tail -n1 | sed 's/v//g'
-}
-
build() {
meson dxvk "build/x64" \