summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2022-05-28 19:08:37 -0300
committerDaniel Bermond2022-05-28 19:08:37 -0300
commit2c557b204c4f89081a7a692d19b30cc490686316 (patch)
treea7e45a9b1e4a30b462a360900efa17639c0641ae
parenta43d236258955f4bda39464700ab79fd2aaaa7b6 (diff)
downloadaur-2c557b204c4f89081a7a692d19b30cc490686316.tar.gz
Switch to sdl2 and clang to fix build
It currently fails to build with sdl1[1] and gcc 12.1.0[2]. [1] https://aur.archlinux.org/packages/d1x-rebirth-git#comment-866582 [2] https://github.com/dxx-rebirth/dxx-rebirth/issues/638#issuecomment-1140335715
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 55a0b57185a1..9a423ab6b874 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dxx-rebirth-git
pkgdesc = A source port of the Descent and Descent 2 engines (git version)
- pkgver = 0.60.0.beta2.r760.g84fb6d499
+ pkgver = 0.60.0.beta2.r1821.g092daecb6
pkgrel = 1
url = https://www.dxx-rebirth.com/
arch = x86_64
@@ -8,12 +8,13 @@ pkgbase = dxx-rebirth-git
license = custom:Parallax
makedepends = git
makedepends = scons
+ makedepends = clang
depends = glu
depends = libgl
depends = libpng
- depends = sdl
- depends = sdl_image
- depends = sdl_mixer
+ depends = sdl2
+ depends = sdl2_image
+ depends = sdl2_mixer
depends = physfs
noextract = d1xr-hires.dxa
noextract = d1xr-sc55-music.dxa
@@ -36,4 +37,3 @@ pkgname = d2x-rebirth-git
pkgdesc = A source port of the Descent 2 engine (git version)
provides = d2x-rebirth
conflicts = d2x-rebirth
-
diff --git a/PKGBUILD b/PKGBUILD
index 53afabe2acd2..c0116fb20f39 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,14 +11,14 @@ _music='sc55' # (sc55/opl3) - update checksums if you change
pkgbase=dxx-rebirth-git
pkgname=('d1x-rebirth-git' 'd2x-rebirth-git')
-pkgver=0.60.0.beta2.r760.g84fb6d499
+pkgver=0.60.0.beta2.r1821.g092daecb6
pkgrel=1
pkgdesc='A source port of the Descent and Descent 2 engines (git version)'
arch=('x86_64')
url='https://www.dxx-rebirth.com/'
license=('GPL3' 'custom:Parallax')
-depends=('glu' 'libgl' 'libpng' 'sdl' 'sdl_image' 'sdl_mixer' 'physfs')
-makedepends=('git' 'scons')
+depends=('glu' 'libgl' 'libpng' 'sdl2' 'sdl2_image' 'sdl2_mixer' 'physfs')
+makedepends=('git' 'scons' 'clang')
source=('git+https://github.com/dxx-rebirth/dxx-rebirth.git'
'https://www.dxx-rebirth.com/download/dxx/res/d1xr-hires.dxa'
"https://www.dxx-rebirth.com/download/dxx/res/d1xr-${_music}-music.dxa"
@@ -32,25 +32,24 @@ sha256sums=('SKIP'
'ace152182c70b9a7ae6f911bddbc239566220a287ab5419cab260d5af739bf16')
pkgver() {
- cd dxx-rebirth
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
+ git -C dxx-rebirth describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
}
build() {
local -a _common_opts=(
"$MAKEFLAGS"
'-Cdxx-rebirth'
- 'lto=1'
- 'sdlmixer=1'
'builddir=./build'
'prefix=/usr'
'opengl=yes'
+ 'sdl2=yes'
'sdlmixer=yes'
'ipv6=yes'
'use_udp=yes'
'use_tracker=yes'
'screenshot=png')
+ export CXX='clang++'
scons "${_common_opts[@]}" 'd1x=1' 'd2x=0' 'sharepath=/usr/share/d1x-rebirth'
scons "${_common_opts[@]}" 'd1x=0' 'd2x=1' 'sharepath=/usr/share/d2x-rebirth'
}