summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-11-10 13:38:29 +0000
committerDaniel Bermond2018-11-10 13:38:29 +0000
commitd5f9b99ae212babd308e9651ee77dc950a300cac (patch)
tree43741a9542c4390f098224b17169ca1b9b6f7e3b
parent7bd4eb243a91aa00cc716788749a26b655db67d3 (diff)
downloadaur-d5f9b99ae212babd308e9651ee77dc950a300cac.tar.gz
Do not rename the source clone
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5ac1cf8c3f9d..360ca80872f8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dxx-rebirth-git
pkgdesc = A source port of the Descent and Descent 2 engines (git version)
- pkgver = 0.60.0.beta2.r201.g4d3612e45
+ pkgver = 0.60.0.beta2.r202.gf6352e795
pkgrel = 1
url = https://www.dxx-rebirth.com/
arch = i686
@@ -15,7 +15,7 @@ pkgbase = dxx-rebirth-git
noextract = d1xr-hires.dxa
noextract = d1xr-sc55-music.dxa
noextract = d2xr-sc55-music.dxa
- source = dxx-rebirth-git::git+https://github.com/dxx-rebirth/dxx-rebirth.git
+ source = git+https://github.com/dxx-rebirth/dxx-rebirth.git
source = https://www.dxx-rebirth.com/download/dxx/res/d1xr-hires.dxa
source = https://www.dxx-rebirth.com/download/dxx/res/d1xr-sc55-music.dxa
source = https://www.dxx-rebirth.com/download/dxx/res/d2xr-sc55-music.dxa
diff --git a/PKGBUILD b/PKGBUILD
index 58c3746a06b3..f0d39fb7792a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,8 +10,9 @@
_music='sc55' # (sc55/opl3) - update checksums if you change
pkgbase=dxx-rebirth-git
+_srcname=dxx-rebirth
pkgname=('d1x-rebirth-git' 'd2x-rebirth-git')
-pkgver=0.60.0.beta2.r201.g4d3612e45
+pkgver=0.60.0.beta2.r202.gf6352e795
pkgrel=1
pkgdesc='A source port of the Descent and Descent 2 engines (git version)'
arch=('i686' 'x86_64')
@@ -19,7 +20,7 @@ url='https://www.dxx-rebirth.com/'
license=('custom')
depends=('sdl_mixer' 'physfs' 'glu' 'libpng')
makedepends=('git' 'scons')
-source=("$pkgbase"::'git+https://github.com/dxx-rebirth/dxx-rebirth.git'
+source=('git+https://github.com/dxx-rebirth/dxx-rebirth.git'
'https://www.dxx-rebirth.com/download/dxx/res/d1xr-hires.dxa'
"https://www.dxx-rebirth.com/download/dxx/res/d1xr-${_music}-music.dxa"
"https://www.dxx-rebirth.com/download/dxx/res/d2xr-${_music}-music.dxa")
@@ -54,14 +55,14 @@ _d2x_opts=('d1x=0'
)
pkgver() {
- cd "$pkgbase"
+ cd "$_srcname"
# git, tags available
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
}
build() {
- cd "$pkgbase"
+ cd "$_srcname"
scons "${_d1x_opts[@]}"
scons "${_d2x_opts[@]}"
@@ -72,7 +73,7 @@ package_d1x-rebirth-git() {
provides=('d1x-rebirth')
conflicts=('d1x-rebirth')
- cd "$pkgbase"
+ cd "$_srcname"
scons install DESTDIR="$pkgdir" "${_d1x_opts[@]}"
@@ -95,7 +96,7 @@ package_d2x-rebirth-git() {
provides=('d2x-rebirth')
conflicts=('d2x-rebirth')
- cd "$pkgbase"
+ cd "$_srcname"
scons install DESTDIR="$pkgdir" "${_d2x_opts[@]}"