summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Beste2017-07-27 08:27:04 -0500
committerDan Beste2017-07-27 08:27:04 -0500
commit1e9485dc7c44b96cfabe061990f223672c1b1c76 (patch)
treed92f100cad8d1e3fc0b9d971d172be264c1ec707
parentbfd71bb4e7da20803bdfaf3d868c19eed340f9b6 (diff)
downloadaur-dybuk-git.tar.gz
gitname -> _gitname
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a1dfbdcaa5d1..bb79ee75fc09 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Co-maintainer: Dan Beste <dan.ray.beste@gmail.com>
pkgname='dybuk-git'
-gitname='dybuk'
+_gitname='dybuk'
pkgver=r37.ef12906
pkgrel=1
pkgdesc='Prettify the ugly Rustc messages'
@@ -10,13 +10,13 @@ arch=('i686' 'x86_64')
url='https://github.com/Ticki/dybuk'
license=('MIT')
makedepends=('cargo' 'git' 'rust')
-provides=("${gitname}")
-conflicts=("${gitname}")
+provides=("${_gitname}")
+conflicts=("${_gitname}")
source=('git+https://github.com/Ticki/dybuk.git')
sha256sums=('SKIP')
pkgver() {
- cd "${gitname}"
+ cd "${_gitname}"
printf "r%s.%s" \
"$(git rev-list --count HEAD)" \
@@ -24,18 +24,18 @@ pkgver() {
}
build() {
- cd "${gitname}"
+ cd "${_gitname}"
cargo build --release
}
package() {
- cd "${gitname}"
+ cd "${_gitname}"
install -m 755 \
- -D target/release/dybuk "${pkgdir}/usr/bin/${gitname}"
+ -D target/release/dybuk "${pkgdir}/usr/bin/${_gitname}"
install -m 644 \
- -D LICENSE "${pkgdir}/usr/share/licenses/${gitname}/LICENSE"
+ -D LICENSE "${pkgdir}/usr/share/licenses/${_gitname}/LICENSE"
}
# vim: ts=2 sw=2 et: