summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Beste2017-07-10 09:53:57 -0500
committerDan Beste2017-07-10 09:53:57 -0500
commitbfd71bb4e7da20803bdfaf3d868c19eed340f9b6 (patch)
treedc3338cb20b06f1fdf699e1b65a48aaa7dc684c4
parent9d05531a30e3d7712333386990e4a42175446982 (diff)
downloadaur-bfd71bb4e7da20803bdfaf3d868c19eed340f9b6.tar.gz
Update PKGBUILD
-rw-r--r--PKGBUILD39
1 files changed, 17 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8f937e6b0462..a1dfbdcaa5d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,46 +1,41 @@
# Maintainer: Aaron DeVore <aaron.devore@gmail.com>
# Co-maintainer: Dan Beste <dan.ray.beste@gmail.com>
-pkgname=dybuk-git
-gitname=dybuk
+pkgname='dybuk-git'
+gitname='dybuk'
pkgver=r37.ef12906
pkgrel=1
pkgdesc='Prettify the ugly Rustc messages'
-arch=(
- 'i686'
- 'x86_64'
-)
+arch=('i686' 'x86_64')
url='https://github.com/Ticki/dybuk'
license=('MIT')
-makedepends=(
- 'cargo'
- 'git'
- 'rust'
-)
+makedepends=('cargo' 'git' 'rust')
provides=("${gitname}")
conflicts=("${gitname}")
source=('git+https://github.com/Ticki/dybuk.git')
sha256sums=('SKIP')
pkgver() {
- cd "${gitname}"
+ cd "${gitname}"
- printf "r%s.%s" \
- "$(git rev-list --count HEAD)" \
- "$(git rev-parse --short HEAD)"
+ printf "r%s.%s" \
+ "$(git rev-list --count HEAD)" \
+ "$(git rev-parse --short HEAD)"
}
build() {
- cd "${gitname}"
+ cd "${gitname}"
- cargo build --release
+ cargo build --release
}
package() {
- cd "${gitname}"
+ cd "${gitname}"
- install -m 755 \
- -D target/release/dybuk "${pkgdir}/usr/bin/${gitname}"
- install -m 644 \
- -D LICENSE "${pkgdir}/usr/share/licenses/${gitname}/LICENSE"
+ install -m 755 \
+ -D target/release/dybuk "${pkgdir}/usr/bin/${gitname}"
+ install -m 644 \
+ -D LICENSE "${pkgdir}/usr/share/licenses/${gitname}/LICENSE"
}
+
+# vim: ts=2 sw=2 et: