summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn K. Luebs2019-10-27 11:32:08 -0400
committerJohn K. Luebs2019-10-27 11:34:21 -0400
commitda380e52eb51aead6b68144ae06c42494d53c418 (patch)
treede167ec792faaf360675a2374fb1d05076de7c6a
parentfff1bbd2f6cc73270cbd38fa5fefda7b60260eef (diff)
downloadaur-da380e52eb51aead6b68144ae06c42494d53c418.tar.gz
Fix cups headers
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
-rw-r--r--cups-2.6-api.patch10
3 files changed, 19 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cd7ddd3c85fd..8a22a2e76a94 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Fri Oct 28 00:15:16 UTC 2016
pkgbase = dymo-cups-drivers
pkgdesc = Official Dymo supplied Linux Cups drivers for LabelWriter series
pkgver = 1.4.0.5
- pkgrel = 3
+ pkgrel = 4
url = http://global.dymo.com/
arch = i686
arch = x86_64
@@ -12,8 +10,10 @@ pkgbase = dymo-cups-drivers
depends = libcups
source = http://download.dymo.com/Software/Linux/dymo-cups-drivers-1.4.0.tar.gz
source = cups-ppd-header.patch
+ source = cups-2.6-api.patch
sha256sums = c60797e7e986ca329f46e9a6ab1cb6382383952b15685ed69fd91f3c7ed64f71
sha256sums = 3a11eaffc5295e4811721b1bd1e51d79ed5e2c5e7665d4be7fc9ce0579fd2a17
+ sha256sums = d256baf5b651c97df1031fde666f9b3e44afbf7df06d42f9f20ae5eaf30d1afe
pkgname = dymo-cups-drivers
diff --git a/PKGBUILD b/PKGBUILD
index a4609d8dba61..438c5c1da705 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
-# Maintainer: John Luebs <jkluebs at luebsphoto dot com>
+# Maintainer: John Luebs <jkluebs@luebsphoto.com>
pkgname=dymo-cups-drivers
pkgver=1.4.0.5
-pkgrel=3
+pkgrel=4
_archive_ver=1.4.0
url=http://global.dymo.com/
pkgdesc="Official Dymo supplied Linux Cups drivers for LabelWriter series"
@@ -10,14 +10,16 @@ arch=('i686' 'x86_64')
license=('GPL' 'LGPL')
depends=('libcups')
source=(http://download.dymo.com/Software/Linux/${pkgname}-${_archive_ver}.tar.gz
- cups-ppd-header.patch)
+ cups-ppd-header.patch cups-2.6-api.patch)
sha256sums=('c60797e7e986ca329f46e9a6ab1cb6382383952b15685ed69fd91f3c7ed64f71'
- '3a11eaffc5295e4811721b1bd1e51d79ed5e2c5e7665d4be7fc9ce0579fd2a17')
+ '3a11eaffc5295e4811721b1bd1e51d79ed5e2c5e7665d4be7fc9ce0579fd2a17'
+ 'd256baf5b651c97df1031fde666f9b3e44afbf7df06d42f9f20ae5eaf30d1afe')
prepare() {
cd "$srcdir/$pkgname-$pkgver"
patch -Np1 -i "$srcdir/cups-ppd-header.patch"
+ patch -Np1 -i "$srcdir/cups-2.6-api.patch"
}
build() {
diff --git a/cups-2.6-api.patch b/cups-2.6-api.patch
new file mode 100644
index 000000000000..9864b0ff9f2c
--- /dev/null
+++ b/cups-2.6-api.patch
@@ -0,0 +1,10 @@
+--- dymo-cups-drivers-1.4.0.5/src/common/CupsPrintEnvironment.cpp.orig 2012-02-07 08:22:37.000000000 -0500
++++ dymo-cups-drivers-1.4.0.5/src/common/CupsPrintEnvironment.cpp 2019-10-27 11:27:37.899169865 -0400
+@@ -23,6 +23,7 @@
+ #include "CupsPrintEnvironment.h"
+ #include <errno.h>
+ #include <cups/cups.h>
++#include <cups/sidechannel.h>
+ #include <cassert>
+
+ namespace DymoPrinterDriver