summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBram Swenson2017-05-29 10:44:46 -0700
committerBram Swenson2017-05-29 10:44:46 -0700
commit2c4a431dcc640f37570893aa9943ed58eb4482c2 (patch)
tree226d0dc731469bd56fa4433ae9aace837b0c250c
downloadaur-2c4a431dcc640f37570893aa9943ed58eb4482c2.tar.gz
dynalist-desktop 1.0.2
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD25
-rwxr-xr-xbuild19
4 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..11a7cff80409
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = dynalist-desktop
+ pkgdesc = Dynalist lets you organize your ideas and tasks in simple lists. It's powerful, yet easy to use.
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://dynalist.io
+ arch = any
+ license = Private
+ makedepends = tar
+ makedepends = wget
+ provides = dynalist
+ source = dynalist.tar.gz::https://dynalist.io/standalone/download?file=dynalist.tar.gz
+ sha256sums = da2587a8b6e436e0d71aba094c72bbef753cbfe585b95477f08ad7c596a943ee
+
+pkgname = dynalist-desktop
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..23a20bde0289
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg/
+/src/
+/*.tar.gz
+/*.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..420e49611b32
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Bram Swenson <bram at craniumisajar dot com> PGP-Key: 9E93532D99D643C0
+
+pkgname=dynalist-desktop
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="Dynalist lets you organize your ideas and tasks in simple lists. It's powerful, yet easy to use."
+arch=("any")
+url="https://dynalist.io"
+license=(Private)
+makedepends=("tar" "wget")
+provides=("dynalist")
+source=("dynalist.tar.gz::https://dynalist.io/standalone/download?file=dynalist.tar.gz")
+sha256sums=("da2587a8b6e436e0d71aba094c72bbef753cbfe585b95477f08ad7c596a943ee")
+
+pkgver() {
+ echo ${pkgver}
+}
+
+package() {
+ mkdir -p "${pkgdir}/opt" "${pkgdir}/usr/bin"
+ cp -a dynalist-${pkgver} "${pkgdir}/opt/dynalist"
+ ln -sf "${pkgdir}/opt/dynalist/dynalist" "${pkgdir}/usr/bin/dynalist"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/build b/build
new file mode 100755
index 000000000000..c8531dbd1d22
--- /dev/null
+++ b/build
@@ -0,0 +1,19 @@
+#!/usr/bin/env bash
+
+make_srcinfo () {
+ makepkg --printsrcinfo > .SRCINFO
+}
+
+build () {
+ makepkg -s
+}
+
+clean () {
+ rm *.pkg.tar.xz *.tar.gz ; rm -rf ./pkg ./src ; true
+}
+
+main () {
+ clean && build && make_srcinfo
+}
+
+main "$@"