summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDušan Simić2022-04-27 14:11:51 +0200
committerDušan Simić2022-04-27 14:11:51 +0200
commita3493b9ff9acd80df6a0ec71b398de2724b8fb73 (patch)
treed2379129035dc6430c26df03514cd8b85af3ea15
downloadaur-a3493b9ff9acd80df6a0ec71b398de2724b8fb73.tar.gz
Add all files
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD35
-rw-r--r--appstream.patch13
4 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3b1ee2798cbb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = dynamic-wallpaper
+ pkgdesc = Dynamic wallpaper creator for Gnome 42
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/dusansimic/dynamic-wallpaper
+ arch = any
+ license = GPL2
+ checkdepends = appstream-glib
+ makedepends = meson
+ makedepends = git
+ depends = python
+ depends = gtk4
+ depends = libadwaita
+ source = git+https://github.com/dusansimic/dynamic-wallpaper#commit=9cc27b273a900e3ee8777887bb27bd531a6e91ea
+ source = appstream.patch
+ md5sums = SKIP
+ md5sums = 4891de83cfdbac11b62b422f55352200
+
+pkgname = dynamic-wallpaper
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6660a1244358
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!PKGBUILD
+!.SRCINFO
+!appstream.patch
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a9715c0ee205
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Dušan Simić <dusan.simic1810@gmail.com>
+
+pkgname=dynamic-wallpaper
+pkgver=0.0.1
+_commit=9cc27b273a900e3ee8777887bb27bd531a6e91ea
+pkgrel=1
+pkgdesc='Dynamic wallpaper creator for Gnome 42'
+arch=(any)
+url=https://github.com/dusansimic/dynamic-wallpaper
+license=(GPL2)
+depends=(python gtk4 libadwaita)
+makedepends=(meson git)
+checkdepends=(appstream-glib)
+source=("git+$url#commit=$_commit"
+ "appstream.patch")
+md5sums=('SKIP'
+ '4891de83cfdbac11b62b422f55352200')
+
+prepare() {
+ cd "$pkgname"
+ patch -p1 -i "$srcdir/appstream.patch"
+}
+
+build() {
+ arch-meson "$pkgname" build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build
+}
+
+package() {
+ meson install -C build --destdir "$pkgdir"
+}
diff --git a/appstream.patch b/appstream.patch
new file mode 100644
index 000000000000..370473d955c8
--- /dev/null
+++ b/appstream.patch
@@ -0,0 +1,13 @@
+diff --git a/data/meson.build b/data/meson.build
+index 9e56ce5..a2571a2 100644
+--- a/data/meson.build
++++ b/data/meson.build
+@@ -40,7 +40,7 @@ appstream_file = i18n.merge_file(
+ appstream_util = find_program('appstream-util', required: false)
+ if appstream_util.found()
+ test('Validate appstream file', appstream_util,
+- args: ['validate', appstream_file]
++ args: ['validate-relax', appstream_file]
+ )
+ endif
+