summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2019-06-10 13:24:01 +0200
committerAlexander F. Rødseth2019-06-10 13:24:01 +0200
commit148f0d7f10eb2abe1d88a69444cd6aaa053fc428 (patch)
treefeb4796cbdf7816ee1c32ed53c1e0f6fe0f634c2
downloadaur-148f0d7f10eb2abe1d88a69444cd6aaa053fc428.tar.gz
Add dynamic wallpaper editor
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD25
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0a66fd09a2e2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Mon Jun 10 11:23:56 UTC 2019
+pkgbase = dynamic-wallpaper-editor
+ pkgdesc = Dynamic Wallpaper Editor
+ pkgver = 1.11.0
+ pkgrel = 1
+ url = https://github.com/maoschanz/dynamic-wallpaper-editor
+ arch = any
+ license = GPL3
+ makedepends = meson
+ makedepends = ninja
+ depends = python
+ depends = hicolor-icon-theme
+ source = dynamic-wallpaper-editor-1.11.0.tar.gz::https://github.com/maoschanz/dynamic-wallpaper-editor/archive/1.11.0.tar.gz
+ sha256sums = 0e34de690bdd969bdccf44a4fd82b544507d0b8afbd1e32339090a658704bf84
+
+pkgname = dynamic-wallpaper-editor
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b3aa581000dd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
+
+pkgname=dynamic-wallpaper-editor
+pkgver=1.11.0
+pkgrel=1
+pkgdesc='Dynamic Wallpaper Editor'
+arch=(any)
+url='https://github.com/maoschanz/dynamic-wallpaper-editor'
+depends=(python hicolor-icon-theme)
+license=(GPL3)
+makedepends=(meson ninja)
+source=("$pkgname-$pkgver.tar.gz::https://github.com/maoschanz/$pkgname/archive/$pkgver.tar.gz")
+sha256sums=('0e34de690bdd969bdccf44a4fd82b544507d0b8afbd1e32339090a658704bf84')
+
+build() {
+ mkdir -p build
+ arch-meson build $pkgname-$pkgver -D werror=false -D b_ndebug=true
+ ninja -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C build install
+}
+
+# vim: ts=2 sw=2 et