summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNahuel Gomez Castro2020-05-13 20:56:08 -0300
committerNahuel Gomez Castro2020-05-13 20:56:08 -0300
commitec6786df6a04caa4f9b4131ae2566142ddac65b4 (patch)
treeee9f6f175736d2e1e85863bd1bea1338032b6433
parentbe99e5921d0682f1119d686bcc0051d8459d605a (diff)
downloadaur-ec6786df6a04caa4f9b4131ae2566142ddac65b4.tar.gz
Updated to v2.5
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore4
-rw-r--r--CHANGELOG18
-rw-r--r--PKGBUILD13
4 files changed, 17 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 649914a6e974..48c6807e52f8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dynamic-wallpaper-editor
pkgdesc = A little utility for creation or edition of GNOME desktop's XML wallpapers
- pkgver = 2.4
+ pkgver = 2.5
pkgrel = 1
url = https://github.com/maoschanz/dynamic-wallpaper-editor
changelog = CHANGELOG
@@ -10,8 +10,8 @@ pkgbase = dynamic-wallpaper-editor
makedepends = git
depends = python
depends = hicolor-icon-theme
- source = git+https://github.com/maoschanz/dynamic-wallpaper-editor.git#tag=2.4
- sha256sums = SKIP
+ source = https://github.com/maoschanz/dynamic-wallpaper-editor/archive/2.5.tar.gz
+ sha256sums = 2b09717c07f68db9a7f2ccf4115ef7351cd9b80f5300870f3bc4545713e9bd6e
pkgname = dynamic-wallpaper-editor
diff --git a/.gitignore b/.gitignore
index d9151297f427..778487ed22d0 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
-/dynamic-wallpaper-editor
/pkg
/src
-*.tar.xz
+*.pkg.tar.xz
+*.tar.gz
diff --git a/CHANGELOG b/CHANGELOG
index d553c960aef6..25fdb6b8fcb0 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,13 +1,11 @@
-v2.4
+v2.5
====
-Add a picture-wide menu with actions such as "Replace with…", thus missing
-pictures can be replaces without the necessity to set the durations again, or
-"View file" to open the file in the system image viewer.
-Wallpaper types are now managed from the primary menu again.
+The images can now be easily sorted according to their filename.
-v2.3
-====
-Add the ability to search among pictures, fix a memory leak, improve the
-automatic duration setting, make the window easier to resize, and update
-translations.
+This update also removes obsolete or unreliable features like "find and replace",
+or the possibility to set a file as lockscreen (which was not possible with most
+environments, and is not even possible GDM since the version 3.36).
+
+Minor bugs have been fixed too, like the weird behavior when closing the "find"
+entry, or actions that were disabled when they shouldn't.
diff --git a/PKGBUILD b/PKGBUILD
index ebb6b948981b..342729dcef0d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Alexander F. Rødseth <xyproto@archlinux.org>
pkgname='dynamic-wallpaper-editor'
-pkgver='2.4'
+pkgver='2.5'
pkgrel='1'
pkgdesc="A little utility for creation or edition of GNOME desktop's XML wallpapers"
changelog='CHANGELOG'
@@ -11,16 +11,11 @@ url="https://github.com/maoschanz/${pkgname}"
license=('GPL3')
depends=('python' 'hicolor-icon-theme')
makedepends=('meson' 'git')
-source=("git+${url}.git#tag=${pkgver}")
-sha256sums=('SKIP')
-
-pkgver () {
- cd ${pkgname}
- git describe --tags | sed 's/-/.r/; s/-/./'
-}
+source=("${url}/archive/${pkgver}.tar.gz")
+sha256sums=('2b09717c07f68db9a7f2ccf4115ef7351cd9b80f5300870f3bc4545713e9bd6e')
build () {
- arch-meson ${pkgname} build
+ arch-meson "${pkgname}-${pkgver}" build
ninja -C build
}