summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNahuel Gomez Castro2019-09-28 14:37:06 -0300
committerNahuel Gomez Castro2019-09-28 14:37:06 -0300
commitecd1b1d2ad9062820fe1b5cf366f508a0bd1b4d2 (patch)
treef056cc5add997c818480ac314e2d35f487e29730
parent148f0d7f10eb2abe1d88a69444cd6aaa053fc428 (diff)
downloadaur-ecd1b1d2ad9062820fe1b5cf366f508a0bd1b4d2.tar.gz
Updated to 2.2.1
-rw-r--r--.SRCINFO14
-rw-r--r--.editorconfig8
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD41
4 files changed, 40 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0a66fd09a2e2..eecb11f415f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,16 @@
-# Generated by mksrcinfo v8
-# Mon Jun 10 11:23:56 UTC 2019
pkgbase = dynamic-wallpaper-editor
- pkgdesc = Dynamic Wallpaper Editor
- pkgver = 1.11.0
+ pkgdesc = A little utility for creation or edition of GNOME desktop's XML wallpapers
+ pkgver = 2.2.1
pkgrel = 1
url = https://github.com/maoschanz/dynamic-wallpaper-editor
- arch = any
+ arch = x86_64
license = GPL3
makedepends = meson
- makedepends = ninja
+ makedepends = git
depends = python
depends = hicolor-icon-theme
- source = dynamic-wallpaper-editor-1.11.0.tar.gz::https://github.com/maoschanz/dynamic-wallpaper-editor/archive/1.11.0.tar.gz
- sha256sums = 0e34de690bdd969bdccf44a4fd82b544507d0b8afbd1e32339090a658704bf84
+ source = git+https://github.com/maoschanz/dynamic-wallpaper-editor.git#tag=2.2.1
+ sha256sums = SKIP
pkgname = dynamic-wallpaper-editor
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 000000000000..1923d4101aa5
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,8 @@
+root = true
+
+[*]
+indent_style = space
+indent_size = 2
+charset = utf-8
+trim_trailing_whitespace = true
+insert_final_newline = true
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d9151297f427
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/dynamic-wallpaper-editor
+/pkg
+/src
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index b3aa581000dd..4fd1c0d0c88f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,28 @@
-# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
+# Maintainer: Nahuel Gomez Castro <nahual_gomca@outlook.com.ar>
+# Contributor: Alexander F. Rødseth <xyproto@archlinux.org>
-pkgname=dynamic-wallpaper-editor
-pkgver=1.11.0
-pkgrel=1
-pkgdesc='Dynamic Wallpaper Editor'
-arch=(any)
-url='https://github.com/maoschanz/dynamic-wallpaper-editor'
-depends=(python hicolor-icon-theme)
-license=(GPL3)
-makedepends=(meson ninja)
-source=("$pkgname-$pkgver.tar.gz::https://github.com/maoschanz/$pkgname/archive/$pkgver.tar.gz")
-sha256sums=('0e34de690bdd969bdccf44a4fd82b544507d0b8afbd1e32339090a658704bf84')
+pkgname='dynamic-wallpaper-editor'
+pkgver='2.2.1'
+pkgrel='1'
+pkgdesc="A little utility for creation or edition of GNOME desktop's XML wallpapers"
+arch=('x86_64')
+url="https://github.com/maoschanz/${pkgname}"
+license=('GPL3')
+depends=('python' 'hicolor-icon-theme')
+makedepends=('meson' 'git')
+source=("git+${url}.git#tag=${pkgver}")
+sha256sums=('SKIP')
-build() {
- mkdir -p build
- arch-meson build $pkgname-$pkgver -D werror=false -D b_ndebug=true
- ninja -C build
+pkgver () {
+ cd ${pkgname}
+ git describe --tags | sed 's/-/.r/; s/-/./'
}
-package() {
- DESTDIR="$pkgdir" ninja -C build install
+build () {
+ arch-meson ${pkgname} build
+ ninja -C build
}
-# vim: ts=2 sw=2 et
+package () {
+ DESTDIR="${pkgdir}" ninja -C build install
+}