summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Hesse2015-06-28 21:54:52 +0200
committerChristian Hesse2015-06-28 21:54:52 +0200
commitc93751fdb29510014bfd7a99d912de2e82d0ffd6 (patch)
tree45a03dc287af1c9728ef2ae0b52231c958d862f7
downloadaur-c93751fdb29510014bfd7a99d912de2e82d0ffd6.tar.gz
initial import of dyndhcpd-git 0.0.9.r0.gdb40123-1
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD40
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..175cdd31a681
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = dyndhcpd-git
+ pkgdesc = start DHCP daemon that dynamically creates configuration based on assigned IP address - git checkout
+ pkgver = 0.0.9.r0.gdb40123
+ pkgrel = 1
+ url = https://github.com/eworm-de/dyndhcpd
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = markdown
+ depends = dhcp
+ optdepends = ipxe: for network boot
+ provides = dyndhcpd
+ conflicts = dyndhcpd
+ backup = etc/dyndhcpd/dhcpd.conf
+ source = git://github.com/eworm-de/dyndhcpd.git
+ sha256sums = SKIP
+
+pkgname = dyndhcpd-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e0082adffc5d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Christian Hesse <mail@eworm.de>
+
+pkgname=dyndhcpd-git
+pkgver=0.0.9.r0.gdb40123
+pkgrel=1
+pkgdesc="start DHCP daemon that dynamically creates configuration based on assigned IP address - git checkout"
+arch=('i686' 'x86_64')
+url="https://github.com/eworm-de/dyndhcpd"
+depends=('dhcp')
+optdepends=('ipxe: for network boot')
+makedepends=('git' 'markdown')
+license=('GPL')
+conflicts=('dyndhcpd')
+provides=('dyndhcpd')
+source=('git://github.com/eworm-de/dyndhcpd.git')
+backup=('etc/dyndhcpd/dhcpd.conf')
+
+pkgver() {
+ cd dyndhcpd/
+
+ if GITTAG="$(git describe --abbrev=0 --tags 2>/dev/null)"; then
+ echo "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG}).r$(git rev-list --count ${GITTAG}..).g$(git log -1 --format="%h")"
+ else
+ echo "0.r$(git rev-list --count master).g$(git log -1 --format="%h")"
+ fi
+}
+
+build() {
+ cd dyndhcpd/
+
+ make
+}
+
+package() {
+ cd dyndhcpd/
+
+ make DESTDIR="${pkgdir}" install
+}
+
+sha256sums=('SKIP')