summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMalstrond2019-06-15 23:42:36 +0200
committerMalstrond2019-06-15 23:42:36 +0200
commit3ec6ec030f4340d6436b891fe106bf3f3ba198a4 (patch)
treef8c2f757ef1a8aeb6080c8d2dd4facf88eb79976
parent88ae28e8ebb2bebfb4eb6a6393bbf942edb8c31a (diff)
downloadaur-3ec6ec030f4340d6436b891fe106bf3f3ba198a4.tar.gz
Updated, dropped Python2 support, resubmitted
-rw-r--r--.SRCINFO42
-rw-r--r--PKGBUILD47
2 files changed, 19 insertions, 70 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d7ee714fbb2b..67d7885fb67d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,44 +1,20 @@
-# Generated by mksrcinfo v8
-# Sat Apr 16 17:30:13 UTC 2016
pkgbase = dyndnsc
- pkgdesc = Dynamic dns (dyndns) update client with support for multiple protocols
- pkgver = 0.4.2
- pkgrel = 2
+ pkgdesc = Dynamic DNS (DynDNS) update client with support for multiple protocols and services. Compatible with IPv4, IPv6 and Dual Stack.
+ pkgver = 0.4.4
+ pkgrel = 0
url = https://github.com/infothrill/python-dyndnsc
arch = any
license = MIT
- makedepends = python-argparse
- makedepends = python-ipy
- makedepends = python-ndg-httpsclient
- makedepends = python-requests
- makedepends = python-setuptools
- makedepends = python2-argparse
- makedepends = python2-ipy
- makedepends = python2-ndg-httpsclient
- makedepends = python2-requests
- makedepends = python2-setuptools
- source = https://pypi.python.org/packages/source/d/dyndnsc/dyndnsc-0.4.2.tar.gz
- source = dyndnsc.service
- md5sums = 1a0c9aa48deb0e65f01e81d95e76f60c
- md5sums = 4b2cd825c387494ba77ad78106dd42eb
- sha512sums = 4b3a8fead2483c6f75a8bf1d6fc1c5ad17210ebf874973a8e5844ea1cec4be1a2ee54d8a00276cc3b128da56b4444c105a4396aed3ff980c2245e0cc3fe43bac
- sha512sums = 29a66551ca796366ca0ed33e858bbfe22f63e04eca7d17530e41be58e557739f9aad983d312f1d79002157ad0e9187e00a70aa9d6481fd761678ec5036b33dcb
-
-pkgname = dyndnsc
depends = python-argparse
depends = python-ipy
depends = python-ndg-httpsclient
depends = python-requests
depends = python-setuptools
- conflicts = dyndnsc-py2
+ depends = python-netifaces
+ source = https://pypi.python.org/packages/source/d/dyndnsc/dyndnsc-0.4.4.tar.gz
+ source = dyndnsc.service
+ md5sums = ba950b33e8869bd40db30605ce701a5c
+ md5sums = 4b2cd825c387494ba77ad78106dd42eb
-pkgname = dyndnsc-py2
- pkgdesc = Dynamic dns (dyndns) update client with support for multiple protocols (Python 2)
- depends = python2-argparse
- depends = python2-ipy
- depends = python2-ndg-httpsclient
- depends = python2-requests
- depends = python2-setuptools
- provides = dyndnsc=0.4.2
- conflicts = dyndnsc
+pkgname = dyndnsc
diff --git a/PKGBUILD b/PKGBUILD
index d9bb6353d170..18bcfaee0133 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,25 @@
-pkgbase=dyndnsc
-pkgname=('dyndnsc' 'dyndnsc-py2')
-pkgver=0.4.2
-pkgrel=2
-pkgdesc="Dynamic dns (dyndns) update client with support for multiple protocols"
+# Maintainer: Malstrond <malstrond@gmail.com>
+# Contributor: xduugu
+
+pkgname=dyndnsc
+pkgver=0.4.4
+pkgrel=0
+pkgdesc="Dynamic DNS (DynDNS) update client with support for multiple protocols and services. Compatible with IPv4, IPv6 and Dual Stack."
arch=('any')
url="https://github.com/infothrill/python-dyndnsc"
license=('MIT')
-makedepends=('python-argparse' 'python-ipy' 'python-ndg-httpsclient' 'python-requests' 'python-setuptools'
- 'python2-argparse' 'python2-ipy' 'python2-ndg-httpsclient' 'python2-requests' 'python2-setuptools')
+depends=('python-argparse' 'python-ipy' 'python-ndg-httpsclient' 'python-requests' 'python-setuptools' 'python-netifaces')
source=("https://pypi.python.org/packages/source/d/dyndnsc/dyndnsc-$pkgver.tar.gz"
'dyndnsc.service')
-md5sums=('1a0c9aa48deb0e65f01e81d95e76f60c'
+md5sums=('ba950b33e8869bd40db30605ce701a5c'
'4b2cd825c387494ba77ad78106dd42eb')
-sha512sums=('4b3a8fead2483c6f75a8bf1d6fc1c5ad17210ebf874973a8e5844ea1cec4be1a2ee54d8a00276cc3b128da56b4444c105a4396aed3ff980c2245e0cc3fe43bac'
- '29a66551ca796366ca0ed33e858bbfe22f63e04eca7d17530e41be58e557739f9aad983d312f1d79002157ad0e9187e00a70aa9d6481fd761678ec5036b33dcb')
-
-prepare() {
- cp -a "dyndnsc-$pkgver"{,-py2}
-}
build() {
cd "$srcdir/dyndnsc-$pkgver"
python setup.py build
-
- cd "$srcdir/dyndnsc-$pkgver-py2"
- python2 setup.py build
}
-package_dyndnsc() {
- depends=('python-argparse' 'python-ipy' 'python-ndg-httpsclient' 'python-requests' 'python-setuptools')
- conflicts=('dyndnsc-py2')
-
+package() {
cd "dyndnsc-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1
@@ -40,19 +29,3 @@ package_dyndnsc() {
# install license file
install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
-
-package_dyndnsc-py2() {
- pkgdesc="$pkgdesc (Python 2)"
- depends=('python2-argparse' 'python2-ipy' 'python2-ndg-httpsclient' 'python2-requests' 'python2-setuptools')
- provides=("dyndnsc=$pkgver")
- conflicts=('dyndnsc')
-
- cd "dyndnsc-$pkgver"-py2
- python2 setup.py install --root="$pkgdir" --optimize=1
-
- # install systemd service file
- install -Dm644 "$srcdir/dyndnsc.service" "$pkgdir/usr/lib/systemd/system/dyndnsc.service"
-
- # install license file
- install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
-}