summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxduugu2016-04-16 00:29:38 +0200
committerxduugu2016-04-16 00:29:38 +0200
commit751294d4006c6de51d08687d06ac9b618099d1f9 (patch)
tree79d85a999205811fee89370fc943eb8ec39bc3f1
downloadaur-751294d4006c6de51d08687d06ac9b618099d1f9.tar.gz
Initial commit
-rw-r--r--.SRCINFO44
-rw-r--r--PKGBUILD58
-rw-r--r--dyndnsc.service9
3 files changed, 111 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..98fff54cda3e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,44 @@
+# Generated by mksrcinfo v8
+# Fri Apr 15 22:29:38 UTC 2016
+pkgbase = dyndnsc
+ pkgdesc = Dynamic dns (dyndns) update client with support for multiple protocols
+ pkgver = 0.4.2
+ pkgrel = 1
+ url = https://github.com/infothrill/python-dyndnsc
+ arch = any
+ license = MIT
+ makedepends = python-argparse
+ makedepends = python-ipy
+ makedepends = python-ndg-httpsclient
+ makedepends = python-requests
+ makedepends = python-setuptools
+ makedepends = python2-argparse
+ makedepends = python2-ipy
+ makedepends = python2-ndg-httpsclient
+ makedepends = python2-requests
+ makedepends = python2-setuptools
+ source = https://pypi.python.org/packages/source/d/dyndnsc/dyndnsc-0.4.2.tar.gz
+ source = dyndnsc.service
+ md5sums = 1a0c9aa48deb0e65f01e81d95e76f60c
+ md5sums = cff3eed55172eb584ac232a575dc8a98
+ sha512sums = 4b3a8fead2483c6f75a8bf1d6fc1c5ad17210ebf874973a8e5844ea1cec4be1a2ee54d8a00276cc3b128da56b4444c105a4396aed3ff980c2245e0cc3fe43bac
+ sha512sums = ae00f342eda9b4ff63b2b18e0825bccd3cc3f9e31fed49e9d8eed472c1c81778b683b2cd6d98b797af573f554ba1a1712bb54bbd7c71f17f04e123217276bce7
+
+pkgname = dyndnsc
+ depends = python-argparse
+ depends = python-ipy
+ depends = python-ndg-httpsclient
+ depends = python-requests
+ depends = python-setuptools
+ conflicts = dyndnsc-py2
+
+pkgname = dyndnsc-py2
+ pkgdesc = Dynamic dns (dyndns) update client with support for multiple protocols (Python 2)
+ depends = python2-argparse
+ depends = python2-ipy
+ depends = python2-ndg-httpsclient
+ depends = python2-requests
+ depends = python2-setuptools
+ provides = dyndnsc=0.4.2
+ conflicts = dyndnsc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..749f9765fd19
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+pkgbase=dyndnsc
+pkgname=('dyndnsc' 'dyndnsc-py2')
+pkgver=0.4.2
+pkgrel=1
+pkgdesc="Dynamic dns (dyndns) update client with support for multiple protocols"
+arch=('any')
+url="https://github.com/infothrill/python-dyndnsc"
+license=('MIT')
+makedepends=('python-argparse' 'python-ipy' 'python-ndg-httpsclient' 'python-requests' 'python-setuptools'
+ 'python2-argparse' 'python2-ipy' 'python2-ndg-httpsclient' 'python2-requests' 'python2-setuptools')
+source=("https://pypi.python.org/packages/source/d/dyndnsc/dyndnsc-$pkgver.tar.gz"
+ 'dyndnsc.service')
+md5sums=('1a0c9aa48deb0e65f01e81d95e76f60c'
+ 'cff3eed55172eb584ac232a575dc8a98')
+sha512sums=('4b3a8fead2483c6f75a8bf1d6fc1c5ad17210ebf874973a8e5844ea1cec4be1a2ee54d8a00276cc3b128da56b4444c105a4396aed3ff980c2245e0cc3fe43bac'
+ 'ae00f342eda9b4ff63b2b18e0825bccd3cc3f9e31fed49e9d8eed472c1c81778b683b2cd6d98b797af573f554ba1a1712bb54bbd7c71f17f04e123217276bce7')
+
+prepare() {
+ cp -a "dyndnsc-$pkgver"{,-py2}
+}
+
+build() {
+ cd "$srcdir/dyndnsc-$pkgver"
+ python setup.py build
+
+ cd "$srcdir/dyndnsc-$pkgver-py2"
+ python2 setup.py build
+}
+
+package_dyndnsc() {
+ depends=('python-argparse' 'python-ipy' 'python-ndg-httpsclient' 'python-requests' 'python-setuptools')
+ conflicts=('dyndnsc-py2')
+
+ cd "dyndnsc-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+
+ # install systemd service file
+ install -Dm644 "$srcdir/dyndnsc.service" "$pkgdir/usr/lib/systemd/system/dyndnsc.service"
+
+ # install license file
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+package_dyndnsc-py2() {
+ pkgdesc="$pkgdesc (Python 2)"
+ depends=('python2-argparse' 'python2-ipy' 'python2-ndg-httpsclient' 'python2-requests' 'python2-setuptools')
+ provides=("dyndnsc=$pkgver")
+ conflicts=('dyndnsc')
+
+ cd "dyndnsc-$pkgver"-py2
+ python2 setup.py install --root="$pkgdir" --optimize=1
+
+ # install systemd service file
+ install -Dm644 "$srcdir/dyndnsc.service" "$pkgdir/usr/lib/systemd/system/dyndnsc.service"
+
+ # install license file
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
diff --git a/dyndnsc.service b/dyndnsc.service
new file mode 100644
index 000000000000..80a4e7e223dc
--- /dev/null
+++ b/dyndnsc.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=dyndnsc
+After=network.target
+
+[Service]
+ExecStart=/usr/bin/dyndnsc --loop --config /etc/dyndnsc.conf
+
+[Install]
+WantedBy=multi-user.target