summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTaijian2021-02-24 22:30:50 +0100
committerTaijian2021-02-24 22:30:50 +0100
commitf9a7b2edc662dd3ed34b3f991f839399f7406779 (patch)
treecfcfdbecd985e6e6bc8d3af595ffff5c5fe7d691
parent055b3d1cd33ac2f9774c3066fe0a4b26f1eb16a0 (diff)
downloadaur-f9a7b2edc662dd3ed34b3f991f839399f7406779.tar.gz
updated to version 0.6.0
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD23
-rw-r--r--dyndnsc.service2
3 files changed, 25 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 17e97aa7eea7..1026b1b6b7ac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,22 @@
pkgbase = dyndnsc
pkgdesc = Dynamic DNS client with support for multiple protocols and services. Compatible with IPv6 dual stack.
- pkgver = 0.5.1
- pkgrel = 0
+ pkgver = 0.6.0
+ pkgrel = 1
url = https://pypi.org/project/dyndnsc
arch = any
license = MIT
- depends = python-argparse
- depends = python-ipy
- depends = python-ndg-httpsclient
+ makedepends = python-pip
+ makedepends = python-wheel
depends = python-requests
depends = python-setuptools
depends = python-netifaces
- source = https://pypi.python.org/packages/source/d/dyndnsc/dyndnsc-0.5.1.tar.gz
+ depends = python-dnspython
+ depends = python-daemonocle
+ depends = python-json-logger
+ source = https://github.com/infothrill/python-dyndnsc/archive/0.6.0.zip
source = dyndnsc.service
- md5sums = 55bc511dbc6d9a9d46f89bcfaa70f37c
- md5sums = 4b2cd825c387494ba77ad78106dd42eb
+ sha256sums = ff0fcd735e96a958fdce51910d962f064c0da6b4b9723e929c1a1e5de2570df0
+ sha256sums = 06e5088696dd2cd6e9af9de51bf0c88e94adadd582cd66620bc260caaf56059c
pkgname = dyndnsc
diff --git a/PKGBUILD b/PKGBUILD
index 896a2158155d..435d68a88d0d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,29 @@
-# Maintainer: Malstrond <malstrond@gmail.com>
-# Contributor: xduugu
+# Maintainer: Taijian <taijian@posteo.de>
+# Contributor: Malstrond <malstrond@gmail.com>
+# Contributor: xduugu
pkgname=dyndnsc
-pkgver=0.5.1
-pkgrel=0
+_pkgname=python-dyndnsc
+pkgver=0.6.0
+pkgrel=1
pkgdesc="Dynamic DNS client with support for multiple protocols and services. Compatible with IPv6 dual stack."
arch=('any')
url="https://pypi.org/project/dyndnsc"
license=('MIT')
-depends=('python-argparse' 'python-ipy' 'python-ndg-httpsclient' 'python-requests' 'python-setuptools' 'python-netifaces')
-source=("https://pypi.python.org/packages/source/d/dyndnsc/dyndnsc-$pkgver.tar.gz"
+depends=('python-requests' 'python-setuptools' 'python-netifaces' 'python-dnspython' 'python-daemonocle' 'python-json-logger')
+makedepends=('python-pip' 'python-wheel')
+source=("https://github.com/infothrill/$_pkgname/archive/$pkgver.zip"
'dyndnsc.service')
-md5sums=('55bc511dbc6d9a9d46f89bcfaa70f37c'
- '4b2cd825c387494ba77ad78106dd42eb')
+sha256sums=('ff0fcd735e96a958fdce51910d962f064c0da6b4b9723e929c1a1e5de2570df0'
+ '06e5088696dd2cd6e9af9de51bf0c88e94adadd582cd66620bc260caaf56059c')
build() {
- cd "$srcdir/dyndnsc-$pkgver"
+ cd "$_pkgname-$pkgver"
python setup.py build
}
package() {
- cd "dyndnsc-$pkgver"
+ cd "$_pkgname-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1
# install systemd service file
diff --git a/dyndnsc.service b/dyndnsc.service
index d8bb9f2a3874..cb80111bbf6c 100644
--- a/dyndnsc.service
+++ b/dyndnsc.service
@@ -5,6 +5,8 @@ After=network.target
[Service]
ExecStart=/usr/bin/dyndnsc --loop --config /etc/dyndnsc.conf
Restart=always
+ProtectSystem=strict
+ProtectHome=true
[Install]
WantedBy=multi-user.target