summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Neumann2019-02-11 10:38:11 +0100
committerRichard Neumann2019-02-11 10:38:11 +0100
commit3b2cdf9a05057624d363b77128bdb353dcbe6e84 (patch)
tree1559d471fa7111fa22861b7b7b76b40ea060db06
downloadaur-3b2cdf9a05057624d363b77128bdb353dcbe6e84.tar.gz
Init.
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD30
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7656108e21af
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = dyndnswatch-git
+ pkgdesc = A simple, lightweight DynDNS watchdog
+ pkgver = r21.3b702d4
+ pkgrel = 1
+ url = https://github.com/coNQP/dyndnswatch
+ arch = any
+ license = GPLv3
+ license = MIT
+ makedepends = git
+ makedepends = python
+ depends = python
+ depends = python-docopt
+ source = dyndnswatch::git+https://github.com/coNQP/dyndnswatch.git
+ md5sums = SKIP
+
+pkgname = dyndnswatch-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d4663c51a8fe
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.pkg.tar.xz*
+dyndnswatch
+src
+pkg
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b14a9424f6b5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Richard Neumann aka. schard <mail at richard dash neumann period de>
+
+_pkgbase='dyndnswatch'
+pkgname="${_pkgbase}-git"
+pkgver=r21.3b702d4
+pkgrel=1
+pkgdesc='A simple, lightweight DynDNS watchdog'
+arch=('any')
+url="https://github.com/coNQP/${_pkgbase}"
+license=('GPLv3' 'MIT')
+depends=('python' 'python-docopt')
+makedepends=('git' 'python')
+source=("${_pkgbase}::git+${url}.git")
+md5sums=('SKIP')
+pkgdir='pkg'
+srcdir='src'
+
+
+pkgver() {
+ cd "${_pkgbase}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+
+package() {
+ cd "${srcdir}/${_pkgbase}"
+ install -Dm 755 dyndnswatchd "${pkgdir}/usr/bin/dyndnswatchd"
+ install -m 755 -d "${pkgdir}/usr/lib/systemd/system"
+ install -m 644 dyndnswatch.service "${pkgdir}/usr/lib/systemd/system"
+}