summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkyechou2020-11-07 17:19:01 -0600
committerkyechou2020-11-07 17:19:01 -0600
commit18c932a04d9971097a585f00acf24bcee7136ad4 (patch)
treea32ce16e5d959127d6c80f9ca8e0b16e4ecab927
parent2d452bafb12b0e46812e3bacf01905238bc57af8 (diff)
downloadaur-18c932a04d9971097a585f00acf24bcee7136ad4.tar.gz
Add git to makedepends
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 39651005eee3..02801fb5abc0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = dyninst-git
pkgdesc = Tools for binary instrumentation, analysis, and modification
pkgver = v10.2.0.r14.g9114187ba
- pkgrel = 1
+ pkgrel = 2
url = https://dyninst.org/
arch = any
license = LGPL
- makedepends = clang
+ makedepends = git
makedepends = cmake
makedepends = boost
depends = libelf
@@ -13,7 +13,7 @@ pkgbase = dyninst-git
depends = boost-libs
provides = dyninst
conflicts = dyninst
- source = dyninst-git::git+https://github.com/dyninst/dyninst.git#branch=clang
+ source = dyninst-git::git+https://github.com/dyninst/dyninst.git
sha256sums = SKIP
pkgname = dyninst-git
diff --git a/PKGBUILD b/PKGBUILD
index 536c391a977f..7f94ce57e0e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,16 @@
pkgname=dyninst-git
pkgver=v10.2.0.r14.g9114187ba
-pkgrel=1
+pkgrel=2
pkgdesc="Tools for binary instrumentation, analysis, and modification"
arch=('any')
url="https://dyninst.org/"
license=('LGPL')
depends=('libelf' 'tbb' 'boost-libs')
-makedepends=('clang' 'cmake' 'boost')
+makedepends=('git' 'cmake' 'boost')
provides=('dyninst')
conflicts=('dyninst')
-source=("$pkgname::git+https://github.com/dyninst/dyninst.git#branch=clang")
+source=("$pkgname::git+https://github.com/dyninst/dyninst.git")
sha256sums=('SKIP')
pkgver() {
@@ -23,8 +23,6 @@ build() {
cd "$srcdir/$pkgname"
mkdir -p build && cd build
cmake \
- -DCMAKE_C_COMPILER=/usr/bin/clang \
- -DCMAKE_CXX_COMPILER=/usr/bin/clang++ \
-DSTERILE_BUILD=ON \
-DENABLE_STATIC_LIBS=YES \
-DCMAKE_INSTALL_PREFIX=/usr \