summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikhail f. Shiryaev2018-09-14 10:52:03 +0200
committerMikhail f. Shiryaev2018-09-14 10:52:03 +0200
commitd9013d5fdaec9550b2f5bf229ecb5b7b381575ad (patch)
treeff2f7800c0053beb6120f802e52ad5b161b0755b
parentef88d0244bd9a07ea76b041f4ab17ffc0abb17e6 (diff)
downloadaur-d9013d5fdaec9550b2f5bf229ecb5b7b381575ad.tar.gz
Update patch, bump release
-rw-r--r--.SRCINFO4
-rw-r--r--0001-sysconfdir.patch19
-rw-r--r--PKGBUILD4
3 files changed, 18 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0a715cdee459..bec1da43d1dc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dynomite-git
pkgdesc = Dynomite is a thin, distributed dynamo layer for different storage engines and protocols
pkgver = 0.6.9.r14.g22b5022
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Netflix/dynomite
arch = i686
arch = x86_64
@@ -11,7 +11,7 @@ pkgbase = dynomite-git
source = git+https://github.com/Netflix/dynomite.git
source = 0001-sysconfdir.patch
md5sums = SKIP
- md5sums = 5131b6f92effc8274f308221ecdfc207
+ md5sums = 60f6ffd7c66d6827a9cd408fdfa2652b
pkgname = dynomite-git
diff --git a/0001-sysconfdir.patch b/0001-sysconfdir.patch
index 9a76e4ef156a..085eb5e306b7 100644
--- a/0001-sysconfdir.patch
+++ b/0001-sysconfdir.patch
@@ -1,5 +1,5 @@
diff --git a/configure.ac b/configure.ac
-index c8a9143..938228c 100644
+index c8a9143..45b653a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -194,6 +194,19 @@ AS_IF([test "x$disable_stats" = xyes],
@@ -9,19 +9,28 @@ index c8a9143..938228c 100644
+AC_ARG_ENABLE([packaging],
+ [AS_HELP_STRING(
+ [--enable-packaging],
-+ [apply packaging standarts])
++ [apply packaging standards])
+ ],
+ [enable_packaging=yes],
+ [enable_packaging=no])
+AS_IF(
+ [test "x$enable_packaging" = xyes],
-+ [AC_DEFINE([PACKAGING], [1], [Define to 1 if stats is not disabled])],
++ [AC_DEFINE([PACKAGING], [1], [Define to 1 if packaging is enabled])],
+ [])
+AC_MSG_RESULT($enable_packaging)
+
# Untar the yaml-0.1.4 in contrib/ before config.status is rerun
AC_CONFIG_COMMANDS_PRE([tar xvfz contrib/yaml-0.1.4.tar.gz -C contrib])
+@@ -206,7 +219,7 @@ AC_CONFIG_FILES([Makefile
+ src/Makefile
+ src/hashkit/Makefile
+ src/proto/Makefile
+- src/entropy/Makefile
++ src/entropy/Makefile
+ src/seedsprovider/Makefile
+ src/event/Makefile
+ src/tools/Makefile])
diff --git a/src/Makefile.am b/src/Makefile.am
index 74c90b7..a8dea61 100644
--- a/src/Makefile.am
@@ -35,12 +44,12 @@ index 74c90b7..a8dea61 100644
AM_CPPFLAGS += -I $(top_srcdir)/src/proto
AM_CPPFLAGS += -I $(top_srcdir)/src/event
diff --git a/src/dynomite.c b/src/dynomite.c
-index 17127c4..dd5e8e2 100644
+index 58bcc1a..7438029 100644
--- a/src/dynomite.c
+++ b/src/dynomite.c
@@ -35,7 +35,11 @@
+ #include "dyn_core.h"
#include "dyn_signal.h"
- #include "dyn_asciilogo.h"
+#if !defined(PACKAGING)
#define DN_CONF_PATH "conf/dynomite.yml"
diff --git a/PKGBUILD b/PKGBUILD
index fa75129f79cf..108d527a8d89 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_gitname=dynomite
pkgname=${_gitname}-git
pkgver=0.6.9.r14.g22b5022
-pkgrel=1
+pkgrel=2
pkgdesc="Dynomite is a thin, distributed dynamo layer for different storage engines and protocols"
arch=('i686' 'x86_64')
url="https://github.com/Netflix/dynomite"
@@ -17,7 +17,7 @@ source=(
)
md5sums=(
'SKIP'
- '5131b6f92effc8274f308221ecdfc207'
+ '60f6ffd7c66d6827a9cd408fdfa2652b'
)
pkgver() {