summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Kubosz2017-01-05 19:23:53 +0100
committerRobert Kubosz2017-01-05 19:24:59 +0100
commit2d02d0a6031eb883942144a649b8b118dbacf3c8 (patch)
tree149f43e4ef4498876cc7c29caca7ca6b129b0cb0
downloadaur-2d02d0a6031eb883942144a649b8b118dbacf3c8.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
-rw-r--r--license21
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e2e7a769edf8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = dyplompwr
+ pkgdesc = Latex package with thesis template for students of Wrocław University of Technology
+ pkgver = 1
+ pkgrel = 1.0
+ url = https://github.com/rkubosz/dyplompwr
+ arch = any
+ license = MIT
+ depends = texlive-core
+ depends = urw-garamond
+ depends = urw-classico
+ source = https://github.com/rkubosz/dyplompwr/releases/download/v1.0/dyplompwr.zip
+ source = license
+ md5sums = be7a7957f5680cb44db2b0cb3f132a1d
+ md5sums = 532f9a8276206a404a50e40544238013
+
+pkgname = dyplompwr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e7a21e0335d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Robert Kubosz <kubosz.robert@gmail.com>
+
+pkgname=dyplompwr
+pkgver=1
+pkgrel=1.0
+_pkgrel=v1.0
+pkgdesc='Latex package with thesis template for students of Wrocław University of Technology'
+arch=('any')
+depends=('texlive-core' 'urw-garamond' 'urw-classico')
+license=('MIT')
+url='https://github.com/rkubosz/dyplompwr'
+source=("https://github.com/rkubosz/dyplompwr/releases/download/$_pkgrel/dyplompwr.zip"
+ 'license')
+md5sums=('be7a7957f5680cb44db2b0cb3f132a1d'
+ '532f9a8276206a404a50e40544238013')
+
+package() {
+ cd "$srcdir"
+ texpath=usr/share/texmf/tex/latex
+ mkdir -p "$pkgdir/$texpath/$pkgname"
+ cp -R "$pkgname" "$pkgdir/$texpath"
+ install -Dm644 license "$pkgdir/usr/share/licenses/$pkgname/license"
+}
diff --git a/license b/license
new file mode 100644
index 000000000000..f000276326d9
--- /dev/null
+++ b/license
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2016 Robert Kubosz
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.