summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuel Mesa2015-07-27 21:13:39 -0500
committerSamuel Mesa2015-07-27 21:13:39 -0500
commit1e154d776a1e0bdd1612f67095bd915ae5c268ff (patch)
tree2835710156cbca4dca2157e8b136ef11ce6ce073
downloadaur-1e154d776a1e0bdd1612f67095bd915ae5c268ff.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD46
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..029a40625576
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = e-foto-svn
+ pkgdesc = A free GNU/GPL educational digital photogrammetric workstation
+ pkgver = 382
+ pkgrel = 1
+ url = http://www.efoto.eng.uerj.br
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = svn
+ makedepends = qt4
+ makedepends = cmake
+ provides = e-foto
+ conflicts = e-foto
+ source = e-foto-svn::svn+https://svn.code.sf.net/p/e-foto/code/trunk
+ md5sums = SKIP
+
+pkgname = e-foto-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..21fee5b00d87
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Samuel Mesa <samuelmesa@linuxmail.org>
+
+_pkgname=e-foto
+pkgname=$_pkgname-svn
+pkgrel=1
+pkgver=382
+pkgdesc="A free GNU/GPL educational digital photogrammetric workstation"
+arch=(i686 x86_64)
+url=http://www.efoto.eng.uerj.br
+license=(GPL2)
+depends=()
+makedepends=('svn' 'qt4' 'cmake')
+optdepends=()
+options=()
+conflicts=('e-foto')
+provides=('e-foto')
+source=($pkgname::svn+https://svn.code.sf.net/p/${_pkgname}/code/trunk)
+md5sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname}
+ svnversion | egrep -o "[0-9]+"
+}
+
+build() {
+ cd ${pkgname}
+ qmake-qt4
+ make -j5
+}
+
+package() {
+ cd ${pkgname}
+ make DESTDIR="$pkgdir" install || return 1
+ mkdir -p ${pkgdir}/usr/{bin,share/{applications,pixmaps}}
+ install -m 755 -p "${srcdir}/bin/e-foto" "${pkgdir}/usr/bin/e-foto"
+ install -D -m644 efoto.ico "${pkgdir}/usr/share/pixmaps/efoto.ico"
+ echo "[Desktop Entry]
+Name=${_pkgname}
+Comment=A free GNU/GPL educational digital photogrammetric workstation
+Exec=/usr/bin/e-foto
+Icon=/usr/share/pixmaps/efoto.ico
+Terminal=false
+Type=Application
+X-MultipleArgs=false
+Categories=GTK;Science;" > "$pkgdir/usr/share/applications/${_pkgname}.desktop"
+} \ No newline at end of file