summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsudokode2015-06-08 20:40:39 -0400
committersudokode2015-06-08 20:40:39 -0400
commit139af4c8cfdb961c3de937e43b3044e63aa554d5 (patch)
tree9c883d73d90ca1791bf328632f52a769712bfea8
downloadaur-139af4c8cfdb961c3de937e43b3044e63aa554d5.tar.gz
init
-rw-r--r--.SRCINFO27
-rw-r--r--MIT-LICENSE25
-rw-r--r--PKGBUILD84
-rw-r--r--e2fsprogs.install20
4 files changed, 156 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7c71ca1b54a2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = e2fsprogs-git
+ pkgdesc = Ext2/3/4 filesystem utilities (git)
+ pkgver = 1.42.12.r488.gad5d05d
+ pkgrel = 1
+ url = http://e2fsprogs.sourceforge.net
+ install = e2fsprogs.install
+ arch = i686
+ arch = x86_64
+ groups = base
+ license = GPL
+ license = LGPL
+ license = MIT
+ makedepends = git
+ makedepends = bc
+ depends = sh
+ depends = util-linux
+ provides = e2fsprogs
+ conflicts = e2fsprogs
+ options = staticlibs
+ backup = etc/mke2fs.conf
+ source = e2fsprogs-git::git://git.kernel.org/pub/scm/fs/ext2/e2fsprogs.git
+ source = MIT-LICENSE
+ sha256sums = SKIP
+ sha256sums = cc45386c1d71f438ad648fd7971e49e3074ad9dbacf9dd3a5b4cb61fd294ecbb
+
+pkgname = e2fsprogs-git
+
diff --git a/MIT-LICENSE b/MIT-LICENSE
new file mode 100644
index 000000000000..d849b28f231e
--- /dev/null
+++ b/MIT-LICENSE
@@ -0,0 +1,25 @@
+Copyright (c) 2003-2007 Theodore Ts'o <tytso@mit.edu>
+Copyright (c) 1997-2003 Yann Dirson <dirson@debian.org>
+Copyright (c) 2001 Alcove <http://www.alcove.com/>
+Copyright (c) 1997 Klee Dienes
+Copyright (c) 1995-1996 Michael Nonweiler <mrn20@cam.ac.uk>
+
+Permission is hereby granted, free of charge, to any person obtaining
+a copy of this software and associated documentation files (the
+"Software"), to deal in the Software without restriction, including
+without limitation the rights to use, copy, modify, merge, publish,
+distribute, sublicense, and/or sell copies of the Software, and to
+permit persons to whom the Software is furnished to do so, subject
+to the following conditions:
+
+The above copyright notice and this permission notice shall be
+included in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY
+KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE
+WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS
+BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN
+AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR
+IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ea8572a71cf2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,84 @@
+# Maintainer: sudokode <sudokode@gmail.com>
+# Contributor: Keshav P R <(the.ridikulus.rat) (aatt) (gemmaeiil) (ddoott) (ccoomm)>
+# Contributor: Matt Parnell <parwok aatt gmail ddoott ccoomm>
+# Contributor: Ronald van Haren <ronald.archlinux.org>
+# Contributor: judd <jvinet@zeroflux.org>
+
+pkgname="e2fsprogs-git"
+pkgver=1.42.12.r488.gad5d05d
+pkgrel=1
+pkgdesc="Ext2/3/4 filesystem utilities (git)"
+arch=('i686' 'x86_64')
+license=('GPL' 'LGPL' 'MIT')
+url="http://e2fsprogs.sourceforge.net"
+groups=('base')
+depends=('sh' 'util-linux')
+makedepends=('git' 'bc')
+conflicts=('e2fsprogs')
+provides=('e2fsprogs')
+backup=('etc/mke2fs.conf')
+install=e2fsprogs.install
+options=('staticlibs')
+source=("$pkgname::git://git.kernel.org/pub/scm/fs/ext2/e2fsprogs.git"
+ 'MIT-LICENSE')
+sha256sums=('SKIP'
+ 'cc45386c1d71f438ad648fd7971e49e3074ad9dbacf9dd3a5b4cb61fd294ecbb')
+
+pkgver() {
+ cd $pkgname
+
+ git describe --long | sed 's/^v//; s/\([^-]*-g\)/r\1/; s/-/./g'
+}
+
+prepare() {
+ cd $pkgname
+
+ # Remove unnecessary init.d directory
+ sed -i '/init\.d/s|^|#|' misc/Makefile.in
+}
+
+build() {
+ cd $pkgname
+
+ ./configure --prefix=/usr \
+ --with-root-prefix="" \
+ --libdir=/usr/lib \
+ --sbindir=/usr/bin \
+ --enable-elf-shlibs \
+ --disable-fsck \
+ --disable-uuidd \
+ --disable-libuuid \
+ --disable-libblkid \
+ --enable-compression \
+ --enable-htree \
+ --enable-blkid-debug \
+ --enable-verbose-makecmds \
+ --enable-e2initrd-helper \
+ --enable-quota \
+ --enable-libquota
+ #--enable-jbd-debug # this likes to break the build
+
+ make
+}
+
+package() {
+ cd $pkgname
+
+ make DESTDIR="$pkgdir" install install-libs
+
+ sed -i 's/^AWK=.*/AWK=awk/' "$pkgdir/usr/bin/compile_et"
+
+ # remove references to build directory
+ sed -i 's#^SS_DIR=.*#SS_DIR="/usr/share/ss"#' "$pkgdir/usr/bin/mk_cmds"
+ sed -i 's#^ET_DIR=.*#ET_DIR="/usr/share/et"#' "$pkgdir/usr/bin/compile_et"
+
+ # remove static libraries with a shared counterpart
+ rm "$pkgdir"/usr/lib/lib{com_err,e2p,ext2fs,ss}.a
+
+ # install MIT license
+ install -Dm644 "$srcdir"/MIT-LICENSE "$pkgdir/usr/share/licenses/e2fsprogs/MIT-LICENSE"
+
+ find "$pkgdir" -type d -name '.git' -exec rm -r '{}' +
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/e2fsprogs.install b/e2fsprogs.install
new file mode 100644
index 000000000000..1a7fe20d7096
--- /dev/null
+++ b/e2fsprogs.install
@@ -0,0 +1,20 @@
+infodir=usr/share/info
+filelist=(libext2fs.info.gz)
+
+post_install() {
+ [ -x usr/bin/install-info ] || return 0
+ for file in ${filelist[@]}; do
+ install-info $infodir/$file $infodir/dir 2> /dev/null
+ done
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ [ -x usr/bin/install-info ] || return 0
+ for file in ${filelist[@]}; do
+ install-info --delete $infodir/$file $infodir/dir 2> /dev/null
+ done
+}