summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCubeTheThird2020-03-08 20:36:15 -0400
committerCubeTheThird2020-03-08 20:36:15 -0400
commitad9cdc54b55edf4294a230c0b557a06f48333ead (patch)
tree31efa15df1d38029ce766cb4293c36a1e94114f0
parent4ddbab2cf38bcd76ab5e510d05756a1ec7fb73ac (diff)
downloadaur-ad9cdc54b55edf4294a230c0b557a06f48333ead.tar.gz
Added patch for cmake boost.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
-rw-r--r--cmake_boost.patch13
3 files changed, 22 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 17d9a59df868..08a8390d9518 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = e4rat-lite-git
pkgdesc = An improved version of e4rat, a toolset to accelerate the boot process and application startups.
pkgver = 2.7.r87.0881c2e
- pkgrel = 5
+ pkgrel = 6
url = https://github.com/ShyPixie/e4rat-lite
install = e4rat-lite-git.install
arch = i686
@@ -25,10 +25,12 @@ pkgbase = e4rat-lite-git
source = e4rat-lite-git.install
source = e4rat-lite-git-update.hook
source = sysmacros_h.patch
+ source = cmake_boost.patch
md5sums = SKIP
md5sums = e0deb0fc92359da3a1970bbab467ffdf
md5sums = b889cd20982a0d95fb694719174f5a11
md5sums = d5fb93378ad2d9f887475ae30302192a
+ md5sums = 6b35884c1df1fe82923539b316719768
pkgname = e4rat-lite-git
diff --git a/PKGBUILD b/PKGBUILD
index 88bb589100e1..02420223a1a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ _gitname=e4rat-lite
pkgdesc="An improved version of e4rat, a toolset to accelerate the boot process and application startups."
url=https://github.com/ShyPixie/$_gitname
pkgver=2.7.r87.0881c2e
-pkgrel=5
+pkgrel=6
arch=(i686 x86_64)
license=('GPL3')
@@ -19,12 +19,14 @@ conflicts=('ureadahead' 'e4rat-preload-lite' 'e4rat-preload-lite-git' 'e4rat-lit
source=("git://github.com/ShyPixie/$_gitname.git"
"$pkgname.install"
"e4rat-lite-git-update.hook"
- "sysmacros_h.patch")
+ "sysmacros_h.patch"
+ "cmake_boost.patch")
md5sums=('SKIP'
'e0deb0fc92359da3a1970bbab467ffdf'
'b889cd20982a0d95fb694719174f5a11'
- 'd5fb93378ad2d9f887475ae30302192a')
+ 'd5fb93378ad2d9f887475ae30302192a'
+ '6b35884c1df1fe82923539b316719768')
install=$pkgname.install
backup=('etc/e4rat-lite.conf')
@@ -49,7 +51,7 @@ prepare() {
cd "$srcdir"/$_gitname
patch -p1 < ../sysmacros_h.patch
-
+ patch -p1 < ../cmake_boost.patch
}
build() {
diff --git a/cmake_boost.patch b/cmake_boost.patch
new file mode 100644
index 000000000000..4ddad6acf001
--- /dev/null
+++ b/cmake_boost.patch
@@ -0,0 +1,13 @@
+diff --git CMakeLists.txt CMakeLists.txt
+index 10969c2..dd28028 100644
+--- e4rat-lite/CMakeLists.txt
++++ e4rat-lite/CMakeLists.txt
+@@ -20,7 +20,7 @@ IF(CMAKE_INSTALL_PREFIX_INITIALIZED_TO_DEFAULT)
+ ENDIF(CMAKE_INSTALL_PREFIX_INITIALIZED_TO_DEFAULT)
+
+ set(Boost_USE_STATIC_LIBS OFF)
+-set(Boost_USE_MULTITHREADED OFF)
++set(Boost_USE_MULTITHREADED ON)
+ find_package(Boost 1.41 COMPONENTS system filesystem regex REQUIRED)
+ set(${PROJECT_NAME}_LIBRARIES ${${PROJECT_NAME}_LIBRARIES}
+ ${Boost_LIBRARIES})