summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCubeTheThird2021-01-17 17:10:00 -0500
committerCubeTheThird2021-01-17 17:10:00 -0500
commite3ef5ae70ed37c5f69da9c86ca5cb66cd87cd08d (patch)
tree81c1c56d0274ad2099b93d4f3da71b25428c04d5
parentad9cdc54b55edf4294a230c0b557a06f48333ead (diff)
downloadaur-e3ef5ae70ed37c5f69da9c86ca5cb66cd87cd08d.tar.gz
Updated upstream source to fix build issues. Removed patches.
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD18
-rw-r--r--cmake_boost.patch13
-rw-r--r--sysmacros_h.patch37
5 files changed, 12 insertions, 71 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 08a8390d9518..a06f5a1dd378 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = e4rat-lite-git
pkgdesc = An improved version of e4rat, a toolset to accelerate the boot process and application startups.
- pkgver = 2.7.r87.0881c2e
- pkgrel = 6
- url = https://github.com/ShyPixie/e4rat-lite
+ pkgver = 2.7.r89.896e93a
+ pkgrel = 1
+ url = https://github.com/LendyZhang/e4rat-lite
install = e4rat-lite-git.install
arch = i686
arch = x86_64
@@ -21,16 +21,12 @@ pkgbase = e4rat-lite-git
conflicts = e4rat-preload-lite-git
conflicts = e4rat-lite
backup = etc/e4rat-lite.conf
- source = git://github.com/ShyPixie/e4rat-lite.git
+ source = git://github.com/LendyZhang/e4rat-lite.git
source = e4rat-lite-git.install
source = e4rat-lite-git-update.hook
- source = sysmacros_h.patch
- source = cmake_boost.patch
md5sums = SKIP
md5sums = e0deb0fc92359da3a1970bbab467ffdf
md5sums = b889cd20982a0d95fb694719174f5a11
- md5sums = d5fb93378ad2d9f887475ae30302192a
- md5sums = 6b35884c1df1fe82923539b316719768
pkgname = e4rat-lite-git
diff --git a/.gitignore b/.gitignore
index fc2ad7f8b2d9..91480c46d29d 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,7 +1,8 @@
# source files
*.pkg.tar.xz
+*.pkg.tar.zst
pkg/**
src/**
build.sh
test.sh
-e4rat-lite/** \ No newline at end of file
+e4rat-lite/**
diff --git a/PKGBUILD b/PKGBUILD
index 02420223a1a6..fa20b137ce97 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,9 @@
pkgname=e4rat-lite-git
_gitname=e4rat-lite
pkgdesc="An improved version of e4rat, a toolset to accelerate the boot process and application startups."
-url=https://github.com/ShyPixie/$_gitname
-pkgver=2.7.r87.0881c2e
-pkgrel=6
+url=https://github.com/LendyZhang/$_gitname
+pkgver=2.7.r89.896e93a
+pkgrel=1
arch=(i686 x86_64)
license=('GPL3')
@@ -16,17 +16,13 @@ optdepends=('bootchart2: A "startup" graphing tool')
conflicts=('ureadahead' 'e4rat-preload-lite' 'e4rat-preload-lite-git' 'e4rat-lite')
-source=("git://github.com/ShyPixie/$_gitname.git"
+source=("git://github.com/LendyZhang/$_gitname.git"
"$pkgname.install"
- "e4rat-lite-git-update.hook"
- "sysmacros_h.patch"
- "cmake_boost.patch")
+ "e4rat-lite-git-update.hook")
md5sums=('SKIP'
'e0deb0fc92359da3a1970bbab467ffdf'
- 'b889cd20982a0d95fb694719174f5a11'
- 'd5fb93378ad2d9f887475ae30302192a'
- '6b35884c1df1fe82923539b316719768')
+ 'b889cd20982a0d95fb694719174f5a11')
install=$pkgname.install
backup=('etc/e4rat-lite.conf')
@@ -50,8 +46,6 @@ prepare() {
fi
cd "$srcdir"/$_gitname
- patch -p1 < ../sysmacros_h.patch
- patch -p1 < ../cmake_boost.patch
}
build() {
diff --git a/cmake_boost.patch b/cmake_boost.patch
deleted file mode 100644
index 4ddad6acf001..000000000000
--- a/cmake_boost.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git CMakeLists.txt CMakeLists.txt
-index 10969c2..dd28028 100644
---- e4rat-lite/CMakeLists.txt
-+++ e4rat-lite/CMakeLists.txt
-@@ -20,7 +20,7 @@ IF(CMAKE_INSTALL_PREFIX_INITIALIZED_TO_DEFAULT)
- ENDIF(CMAKE_INSTALL_PREFIX_INITIALIZED_TO_DEFAULT)
-
- set(Boost_USE_STATIC_LIBS OFF)
--set(Boost_USE_MULTITHREADED OFF)
-+set(Boost_USE_MULTITHREADED ON)
- find_package(Boost 1.41 COMPONENTS system filesystem regex REQUIRED)
- set(${PROJECT_NAME}_LIBRARIES ${${PROJECT_NAME}_LIBRARIES}
- ${Boost_LIBRARIES})
diff --git a/sysmacros_h.patch b/sysmacros_h.patch
deleted file mode 100644
index b95bf0264534..000000000000
--- a/sysmacros_h.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-diff -Naur -b '--to-file=e4rat-lite-patched/src/' -x '*.o' -x '*.tu' e4rat-lite/src/device.cc e4rat-lite-patched/src/device.cc
---- e4rat-lite/src/device.cc 2018-09-20 19:40:39.823493172 +0530
-+++ e4rat-lite-patched/src/device.cc 2018-09-20 19:54:10.323375842 +0530
-@@ -32,6 +32,8 @@
-
- #include <boost/lexical_cast.hpp>
-
-+#include <sys/sysmacros.h>
-+
- #define BLOCKS_PER_GROUP(fs) (fs->super->s_blocks_per_group)
- #define BLOCKS_PER_FLEX(fs) (BLOCKS_PER_GROUP(fs) << fs->super->s_log_groups_per_flex)
- #define FREE_BLOCKS_PER_GROUP(fs) ( BLOCKS_PER_GROUP(fs) \
-
-diff -Naur -b '--to-file=e4rat-lite-patched/src/' -x '*.o' -x '*.tu' e4rat-lite/src/e4rat-collect.cc e4rat-lite-patched/src/e4rat-collect.cc
---- e4rat-lite/src/e4rat-collect.cc 2018-09-20 19:40:39.823493172 +0530
-+++ e4rat-lite-patched/src/e4rat-collect.cc 2018-09-20 19:59:25.503867639 +0530
-@@ -48,6 +48,8 @@
-
- #include <boost/foreach.hpp>
-
-+#include <sys/sysmacros.h>
-+
- #define PID_FILE "/dev/.e4rat-lite-collect.pid"
- #define MATCH(s, n) strcmp(section, s) == 0 && strcmp(name, n) == 0
-
-diff -Naur -b '--to-file=e4rat-lite-patched/src/' -x '*.o' -x '*.tu' e4rat-lite/src/listener.cc e4rat-lite-patched/src/listener.cc
---- e4rat-lite/src/listener.cc 2018-09-20 19:40:39.826826547 +0530
-+++ e4rat-lite-patched/src/listener.cc 2018-09-20 20:04:09.833981860 +0530
-@@ -43,6 +43,8 @@
-
- #include <fstream>
-
-+#include <sys/sysmacros.h>
-+
- std::string getProcessName(pid_t pid)
- {
- std::string comm;