summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Jacob2016-04-21 21:31:13 +0200
committerFlorian Jacob2016-04-21 21:31:13 +0200
commit42bc9299dc0d9f39d74870fdb0937c35082376c7 (patch)
tree6ae62249d0e4a2b3521c198742a5c03d9c2d0c90
parent407f6bc33dce57d0c192f1e8d5ee5352cd1a3d1d (diff)
downloadaur-42bc9299dc0d9f39d74870fdb0937c35082376c7.tar.gz
do install script by ourselves again
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 835e09652a04..288945e0c0fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Your Name <youremail@domain.com>
pkgname=earlyoom
pkgver=0.10
-pkgrel=1
+pkgrel=2
pkgdesc="Early OOM Daemon for Linux"
arch=('any')
url="https://github.com/rfjakob/earlyoom"
@@ -9,15 +9,19 @@ license=('MIT')
source=(
"https://github.com/florianjacob/$pkgname/archive/v$pkgver.tar.gz"
)
-md5sums=('5e3de7040c8a703cacabc6c582c44b5f')
+md5sums=('da4e9939aee80e31f8ea63c8e8ce1f38')
build() {
cd "$pkgname-$pkgver"
+ # earlyoom tries to get the version number from the git repo, but we're packaging tarballs here, so that would fail.
make VERSION=$pkgver
}
package() {
cd "$pkgname-$pkgver"
- make VERSION=$pkgver DESTDIR="$pkgdir" PREFIX=/usr install
+ # earlyoom's install script doesn't support a staged build or prefix configuration, so do this by hand.
+ install -D -m 755 ./earlyoom "$pkdgir/usr/bin/earyloom"
+ install -D -m 644 ./earlyoom.service "$pkgdir/usr/lib/systemd/system/earlyoom.service"
+ sed -i s|/usr/local/bin/earlyoom|/usr/bin/earlyoom|g "$pkgdir/lib/systemd/system/earlyoom.service"
}