summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Jacob2016-04-16 12:02:31 +0200
committerFlorian Jacob2016-04-16 12:02:31 +0200
commit8ca3c412f1edbc4f0ae63a0162e8f3c64738cfd0 (patch)
treecc190f79b78a207baa099a212de59099f2afd08a
parentf43023321e7ac07c18f8908ba71f9e1e41657b45 (diff)
downloadaur-8ca3c412f1edbc4f0ae63a0162e8f3c64738cfd0.tar.gz
add support for DESTDIR and PREFIX
-rw-r--r--PKGBUILD11
1 files changed, 1 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8389e110806c..6c042c03f08d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,9 +11,6 @@ source=(
)
md5sums=('59fe2bff6677686a76e6aaec5b4b2be8')
-# TODO: wirft Fehler weil wir nicht in einem gitrepo sind, da im Makefile irgendwie GITVERSION per git gesetzt wird.
-# Wie wärs: GITVERSION zu VERSION umbenennen, und wenn sie für's script noch nicht von außerhalb gesetzt ist, dann per
-# git berechnen? Dann kann ich da meine $pkgver reinwerfen.
build() {
cd "$pkgname-$pkgver"
make VERSION=$pkgver
@@ -22,11 +19,5 @@ build() {
package() {
cd "$pkgname-$pkgver"
- # earlyoom's make install script can't be parameterized for a location, therefore do it by hand.
- install -d "${pkgdir}/usr/bin/"
- install -d "${pkgdir}/usr/lib/systemd/system/"
- # TODO: Das service-file will /usr/local/bin/earlyoom starten, und hat auch sonst komische Optionen
- # sed oder ganz neu.
- install -m 644 ./earlyoom.service "${pkgdir}/usr/lib/systemd/system/earlyoom.service"
- install -m 755 ./earlyoom "${pkgdir}/usr/bin/earlyoom"
+ make DESTDIR="$pkgdir" PREFIX=/usr install
}