summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoristimaldar2020-12-18 20:52:40 +0300
committeristimaldar2020-12-18 20:52:40 +0300
commit0a1f34ad8780db8d50abc8f6580497018bca9f07 (patch)
tree7a83ce826300ffad2f74f3725f2c446243f78809
parent919f3bc164cc7939859c261facde56f42839d7d7 (diff)
downloadaur-0a1f34ad8780db8d50abc8f6580497018bca9f07.tar.gz
v0.4.0
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD13
3 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d88ac7cef057..cc45dfb6eb3e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = earthly-bin
pkgdesc = Build automation for the container era
- pkgver = 0.3.19
+ pkgver = 0.4.0
pkgrel = 1
url = https://earthly.dev
install = earthly-bin.install
@@ -8,7 +8,8 @@ pkgbase = earthly-bin
license = MPL-2.0
depends = docker
depends = git
- source = https://github.com/earthly/earthly/releases/download/v0.3.19/earth-linux-amd64
- sha512sums = f4a3db97071e58bd568e2fff1da7dc1336eb0bbf044a2dc28079015448eabb679f8e04771304cbbd2cb9aab5ca65a27c23bcdce9f4d74f555b1fa67d02885eed
+ source = https://github.com/earthly/earthly/releases/download/v0.4.0/earthly-linux-amd64
+ sha512sums = c2c52d5e0547a7f67efbfb7381713854952e1aa930c920238bbdaa4a92a998a2239175dbe322379f22b1a76a3da3dd44b3781f0467f741f5ba4997641ef09592
pkgname = earthly-bin
+
diff --git a/.gitignore b/.gitignore
index 6aca2724c5d8..4ecdcc60a38a 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
src/
pkg/
*.pkg.tar.zst
-earth-linux*
+earthly-linux*
diff --git a/PKGBUILD b/PKGBUILD
index 7fee4bfccd9a..f63a66c3f9c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,30 @@
# Maintainer: istimaldar_sntlk <istimaldar@gmail.com>
pkgname=earthly-bin
-pkgver=0.3.19
+pkgver=0.4.0
pkgrel=1
pkgdesc='Build automation for the container era'
arch=('x86_64')
url='https://earthly.dev'
license=('MPL-2.0')
-install=earthly-bin.install
+install=${pkgname}.install
depends=(
'docker'
'git'
)
source=(
- "https://github.com/earthly/earthly/releases/download/v${pkgver}/earth-linux-amd64"
+ "https://github.com/earthly/earthly/releases/download/v${pkgver}/earthly-linux-amd64"
)
sha512sums=(
- 'f4a3db97071e58bd568e2fff1da7dc1336eb0bbf044a2dc28079015448eabb679f8e04771304cbbd2cb9aab5ca65a27c23bcdce9f4d74f555b1fa67d02885eed'
+ 'c2c52d5e0547a7f67efbfb7381713854952e1aa930c920238bbdaa4a92a998a2239175dbe322379f22b1a76a3da3dd44b3781f0467f741f5ba4997641ef09592'
)
prepare() {
- chmod +x earth-linux-amd64
+ chmod +x earthly-linux-amd64
}
package() {
mkdir -p "${pkgdir}/usr/bin"
- cp "${srcdir}/earth-linux-amd64" "${pkgdir}/usr/bin/earth"
+ cp "${srcdir}/earthly-linux-amd64" "${pkgdir}/usr/bin/earthly"
+ ln -s "${pkgdir}/usr/bin/earthly" "${pkgdir}/usr/bin/earth"
}