summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoristimaldar2020-12-08 01:28:24 +0300
committeristimaldar2020-12-08 01:28:24 +0300
commit919f3bc164cc7939859c261facde56f42839d7d7 (patch)
tree6b430363d4a4838e6454d5f8c9eeaf1419d51739
downloadaur-919f3bc164cc7939859c261facde56f42839d7d7.tar.gz
v0.3.19
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD29
-rwxr-xr-xearthly-bin.install8
4 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d88ac7cef057
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = earthly-bin
+ pkgdesc = Build automation for the container era
+ pkgver = 0.3.19
+ pkgrel = 1
+ url = https://earthly.dev
+ install = earthly-bin.install
+ arch = x86_64
+ license = MPL-2.0
+ depends = docker
+ depends = git
+ source = https://github.com/earthly/earthly/releases/download/v0.3.19/earth-linux-amd64
+ sha512sums = f4a3db97071e58bd568e2fff1da7dc1336eb0bbf044a2dc28079015448eabb679f8e04771304cbbd2cb9aab5ca65a27c23bcdce9f4d74f555b1fa67d02885eed
+
+pkgname = earthly-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6aca2724c5d8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src/
+pkg/
+*.pkg.tar.zst
+earth-linux*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7fee4bfccd9a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: istimaldar_sntlk <istimaldar@gmail.com>
+pkgname=earthly-bin
+pkgver=0.3.19
+pkgrel=1
+pkgdesc='Build automation for the container era'
+arch=('x86_64')
+url='https://earthly.dev'
+license=('MPL-2.0')
+install=earthly-bin.install
+depends=(
+ 'docker'
+ 'git'
+)
+
+source=(
+ "https://github.com/earthly/earthly/releases/download/v${pkgver}/earth-linux-amd64"
+)
+sha512sums=(
+ 'f4a3db97071e58bd568e2fff1da7dc1336eb0bbf044a2dc28079015448eabb679f8e04771304cbbd2cb9aab5ca65a27c23bcdce9f4d74f555b1fa67d02885eed'
+)
+
+prepare() {
+ chmod +x earth-linux-amd64
+}
+
+package() {
+ mkdir -p "${pkgdir}/usr/bin"
+ cp "${srcdir}/earth-linux-amd64" "${pkgdir}/usr/bin/earth"
+}
diff --git a/earthly-bin.install b/earthly-bin.install
new file mode 100755
index 000000000000..e480bcef5b65
--- /dev/null
+++ b/earthly-bin.install
@@ -0,0 +1,8 @@
+post_install() {
+ echo -e "\e[1mAutocomplete\e[0m:"
+ echo -e " To enable shell autocomplete run \e[1mearth bootstrap\e[0m"
+}
+
+post_upgrade() {
+ post_install
+}