summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2018-09-11 09:55:36 +0430
committerMohammadreza Abdollahzadeh2018-09-11 09:55:36 +0430
commitfd4f04014bdbd6eba73c3832ba81c642b9a31610 (patch)
tree3ecf406108b84bb362447f740fb3b616330e2bdc
downloadaur-fd4f04014bdbd6eba73c3832ba81c642b9a31610.tar.gz
initial import
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD56
-rw-r--r--earthworm.install5
-rw-r--r--profile.d_earthworm.sh2
-rw-r--r--systemd_sysusers.d_earthworm.conf1
-rw-r--r--systemd_tmpfiles.d_earthworm.conf1
6 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..185cefaa8416
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = earthworm-svn
+ pkgdesc = An open architecture, open source public software for seismic data acquisition, processing, archival and distribution.
+ pkgver = r7559
+ pkgrel = 1
+ url = http://www.earthwormcentral.org/
+ install = earthworm.install
+ arch = x86_64
+ license = custom:ISTI
+ makedepends = gcc-fortran
+ makedepends = libtirpc
+ makedepends = subversion
+ provides = earthworm
+ conflicts = earthworm
+ source = earthworm::svn+svn://svn.isti.com/earthworm/trunk
+ source = profile.d_earthworm.sh
+ source = systemd_sysusers.d_earthworm.conf
+ source = systemd_tmpfiles.d_earthworm.conf
+ sha256sums = SKIP
+ sha256sums = c83cc383842684fba22a184fcf9be69d7a5e31aa83e3f0bf4b357b65338c2c33
+ sha256sums = 5a75a172f53720ea9fb5bb85e2210788db33f2c3a5c352eed9435378ebc7acbd
+ sha256sums = aeb2d9caf736a62cb6d7631b589391343d4469e319bae606192bf8c51fccfe0e
+
+pkgname = earthworm-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..99258585c051
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# $Id$
+# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
+pkgname=earthworm-svn
+pkgver=r7559
+pkgrel=1
+pkgdesc="An open architecture, open source public software for seismic data acquisition, processing, archival and distribution."
+arch=('x86_64')
+url="http://www.earthwormcentral.org/"
+license=('custom:ISTI')
+makedepends=('gcc-fortran' 'libtirpc' 'subversion')
+provides=("${pkgname%-svn}")
+conflicts=("${pkgname%-svn}")
+install=${pkgname%-svn}.install
+source=("${pkgname%-svn}::svn+svn://svn.isti.com/${pkgname%-svn}/trunk"
+ "profile.d_${pkgname%-svn}.sh"
+ "systemd_sysusers.d_${pkgname%-svn}.conf"
+ "systemd_tmpfiles.d_${pkgname%-svn}.conf")
+sha256sums=('SKIP'
+ 'c83cc383842684fba22a184fcf9be69d7a5e31aa83e3f0bf4b357b65338c2c33'
+ '5a75a172f53720ea9fb5bb85e2210788db33f2c3a5c352eed9435378ebc7acbd'
+ 'aeb2d9caf736a62cb6d7631b589391343d4469e319bae606192bf8c51fccfe0e')
+
+pkgver() {
+ cd "${srcdir}/${pkgname%-svn}"
+ printf "r%s" "$(svnversion | tr -d 'A-z')"
+}
+
+prepare() {
+ cd "${srcdir}/${pkgname%-svn}/environment"
+ sed -i 's|#USE_CC_BITS=true|USE_CC_BITS=true|' ew_linux.bash
+ echo 'export LINK_LIBS="${LINK_LIBS} -ltirpc -fPIC"' >> ew_linux.bash
+ echo 'export CFLAGS="${GLOBALFLAGS} -I/usr/include/tirpc -fPIC"' >> ew_linux.bash
+ echo 'export CXXFLAGS="${GLOBALFLAGS} -I/usr/include/tirpc -fPIC"' >> ew_linux.bash
+ echo 'export GLOBALFLAGS="${GLOBALFLAGS} -I/usr/include/tirpc -fPIC"' >> ew_linux.bash
+}
+
+build() {
+ cd "${srcdir}/${pkgname%-svn}"
+ export EW_INSTALL_HOME=${srcdir}
+ export EW_INSTALL_VERSION="${pkgname%-svn}"
+ source $EW_INSTALL_HOME/$EW_INSTALL_VERSION/environment/ew_linux.bash
+ cd $EW_INSTALL_HOME/$EW_INSTALL_VERSION/src
+ make unix
+}
+
+package() {
+ install -d "$pkgdir/opt"
+ cp -a ${pkgname%-svn} "${pkgdir}/opt/"
+ install -Dm644 "${srcdir}"/profile.d_${pkgname%-svn}.sh \
+ "${pkgdir}"/etc/profile.d/${pkgname%-svn}.sh
+ install -Dm644 "${srcdir}"/systemd_sysusers.d_${pkgname%-svn}.conf \
+ "${pkgdir}"/usr/lib/sysusers.d/${pkgname%-svn}.conf
+ install -Dm644 "${srcdir}"/systemd_tmpfiles.d_${pkgname%-svn}.conf \
+ "${pkgdir}"/usr/lib/tmpfiles.d/${pkgname%-svn}.conf
+}
+# vim:set ts=2 sw=2 et:
diff --git a/earthworm.install b/earthworm.install
new file mode 100644
index 000000000000..3a8db2e33205
--- /dev/null
+++ b/earthworm.install
@@ -0,0 +1,5 @@
+post_install() {
+ echo -e "\e[1;33m==> NOTICE:\e[0m before using this software"
+ echo -e "\e[1;32m==>\e[0m Add your user to earthworm group and relogin:"
+ echo " sudo gpasswd -a $USER earthworm"
+}
diff --git a/profile.d_earthworm.sh b/profile.d_earthworm.sh
new file mode 100644
index 000000000000..3ff3b443a09e
--- /dev/null
+++ b/profile.d_earthworm.sh
@@ -0,0 +1,2 @@
+#add earthworm bin to path environment variable
+export PATH=${PATH}:/opt/earthworm/bin
diff --git a/systemd_sysusers.d_earthworm.conf b/systemd_sysusers.d_earthworm.conf
new file mode 100644
index 000000000000..86770c972d10
--- /dev/null
+++ b/systemd_sysusers.d_earthworm.conf
@@ -0,0 +1 @@
+u earthworm - "Earthworm user"
diff --git a/systemd_tmpfiles.d_earthworm.conf b/systemd_tmpfiles.d_earthworm.conf
new file mode 100644
index 000000000000..f0db1cf09c29
--- /dev/null
+++ b/systemd_tmpfiles.d_earthworm.conf
@@ -0,0 +1 @@
+Z /opt/earthworm/params 0775 earthworm earthworm