summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzeFresk2022-07-25 18:29:58 +0200
committerzeFresk2022-07-25 18:29:58 +0200
commit6227eb28e36b291a38d41b6fb5f2177149521736 (patch)
treebaf15cff45a7c068e1e0f11336a56dc3f2f4930c
parentc1909707638feebc86580b01d736f4dd1babb81d (diff)
downloadaur-6227eb28e36b291a38d41b6fb5f2177149521736.tar.gz
Update for CMake
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD10
2 files changed, 6 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 463171c2fa33..4b56bd455ca3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = easena-git
pkgdesc = EAsy Specification of Evolutionary and Neural Algorithms is an Artificial Evolution platform developped by the SONIC (Stochastic Optimisation and Nature Inspired Computing) group of the BFO team at Université de Strasbourg.
- pkgver = r441.07415e8
+ pkgver = r449.g33c1f75
pkgrel = 2
url = http://easea.unistra.fr
arch = i686
@@ -12,9 +12,6 @@ pkgbase = easena-git
depends = flex
depends = bison
depends = valgrind
- depends = java-environment
- depends = cuda
- depends = r
provides = easena
provides = easea
conflicts = easea
diff --git a/PKGBUILD b/PKGBUILD
index 0e7104ffa32a..ef59f1cc41c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Léo Chéneau <leocheneau+arch@gmail.com>
pkgname=easena-git
-pkgver=r441.07415e8
+pkgver=r449.g33c1f75
pkgrel=2
pkgdesc="EAsy Specification of Evolutionary and Neural Algorithms is an Artificial Evolution platform developped by the SONIC (Stochastic Optimisation and Nature Inspired Computing) group of the BFO team at Université de Strasbourg. "
arch=(i686 x86_64)
url="http://easea.unistra.fr"
license=('AGPL3')
-depends=(cmake flex bison valgrind java-environment cuda r)
+depends=(cmake flex bison valgrind)
makedepends=(make gcc)
provides=(easena easea)
conflicts=(easea)
@@ -24,15 +24,15 @@ pkgver() {
prepare() {
cd easea
#patch --forward --strip=1 --input="${srcdir}/fix_config.patch"
+ cmake -B build -DCMAKE_BUILD_TYPE=Release
}
build() {
cd easea
- cmake .
- make
+ cmake --build build --config Release
}
package() {
cd easea
- make DESTDIR="$pkgdir/" install
+ cmake --install build --prefix "$pkgdir"
}