summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIlja Kocken2018-03-26 18:07:59 +0200
committerIlja Kocken2018-03-26 18:07:59 +0200
commit30f5cf0fb8b05887d8b39fe96ed434b94751b993 (patch)
tree1e9a7dd7baa16b300cae87da7f275ae6891f8f89
downloadaur-30f5cf0fb8b05887d8b39fe96ed434b94751b993.tar.gz
clean commit
-rw-r--r--.SRCINFO23
-rw-r--r--LICENSE7
-rw-r--r--PKGBUILD31
-rw-r--r--easotope-client.desktop11
-rw-r--r--easotope-client.sh4
-rw-r--r--icon.pngbin0 -> 5084 bytes
6 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7d2f27e8481c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = easotope-client
+ pkgdesc = Client for making isotopes easy
+ pkgver = 20180218
+ pkgrel = 1
+ url = http://easotope.org
+ arch = x86_64
+ license = GPL3
+ license = EPL
+ license = custom:easotope
+ depends = gtk3
+ source = http://easotope.org/release/20180218/easotope_client_linux_x86_64.tar.gz
+ source = LICENSE
+ source = icon.png
+ source = easotope-client.sh
+ source = easotope-client.desktop
+ md5sums = db052a657ebef6e0661ec00b22934823
+ md5sums = 86ddc7fdc30acbb5146c9820c1b771f1
+ md5sums = 35db741960c2d1edd88d3c4f2a47d028
+ md5sums = 03f873d4be21190aa4b4d26becafd5e7
+ md5sums = 2f695968419ab83fc2ba6fc7de412d6a
+
+pkgname = easotope-client
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..a625476f95f5
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,7 @@
+Copyright © 2016-2017 Devon Bowen, Switzerland
+
+This program is free software; you can redistribute it and/or modify it under the terms of the GNU General Public License as published by the Free Software Foundation, version 3 of the License.
+
+Additional permission under GNU GPL version 3 section 7: if you modify this Program, or any covered work, by linking or combining it with the Eclipse Rich Client Platform (or a modified version of that library), containing parts covered by the terms of the Eclipse Public License, the licensors of this Program grant you additional permission to convey the resulting work. Corresponding Source for a non-source form of such a combination shall include the source code for the parts of the Eclipse Rich Client Platform used as well as that of the covered work.
+
+This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5eec729b2bd0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Ilja Kocken <i.j.kocken at uu dot com>
+pkgname=easotope-client
+pkgver=20180218
+pkgrel=1
+pkgdesc="Client for making isotopes easy"
+arch=('x86_64')
+url="http://easotope.org"
+license=('GPL3'
+ 'EPL'
+ 'custom:easotope')
+depends=('gtk3')
+source=("${url}/release/${pkgver}/${pkgname//-/_}_linux_x86_64.tar.gz"
+ "LICENSE"
+ "icon.png"
+ "${pkgname}.sh"
+ "${pkgname}.desktop")
+md5sums=('db052a657ebef6e0661ec00b22934823'
+ '86ddc7fdc30acbb5146c9820c1b771f1'
+ '35db741960c2d1edd88d3c4f2a47d028'
+ '03f873d4be21190aa4b4d26becafd5e7'
+ '2f695968419ab83fc2ba6fc7de412d6a')
+package() {
+ install -dm755 "${pkgdir}/opt/"
+ cd "${srcdir}"
+ cp -r "${pkgname//-/_}/" "${pkgdir}/opt/${pkgname}/"
+
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 "icon.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ install -Dm644 "${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -D "${pkgname}.sh" "${pkgdir}/usr/bin/${pkgname}"
+}
diff --git a/easotope-client.desktop b/easotope-client.desktop
new file mode 100644
index 000000000000..a8154f22ff05
--- /dev/null
+++ b/easotope-client.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=easotope-client
+Exec=/usr/bin/easotope-client
+Icon=easotope-client
+Terminal=false
+Type=Application
+Categories=Science;
+StartupNotify=False
+Comment=Making isotopes easy
+Name[en_US]=easotope-client
diff --git a/easotope-client.sh b/easotope-client.sh
new file mode 100644
index 000000000000..2772243c139f
--- /dev/null
+++ b/easotope-client.sh
@@ -0,0 +1,4 @@
+#!/usr/bin/sh
+export EASOTOPE_LOG_DIR="${XDG_DATA_HOME:-$HOME}/.easotope-client"
+mkdir -p $EASOTOPE_LOG_DIR
+exec /opt/easotope-client/linux.gtk.x86_64/eclipse/easotope -data "$EASOTOPE_LOG_DIR"
diff --git a/icon.png b/icon.png
new file mode 100644
index 000000000000..f174eb49c9e7
--- /dev/null
+++ b/icon.png
Binary files differ