aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsteadfasterX2020-12-29 10:06:03 +0100
committersteadfasterX2020-12-29 10:24:43 +0100
commit3ea78046eb035e516d8f0b9499a7786d6cd62f39 (patch)
tree9ade70137ec8eff3ccb8c1370b82999c7ffecbea
parent10b7407fbbe95543dc67b6f084342a80ad4fec65 (diff)
downloadaur-3ea78046eb035e516d8f0b9499a7786d6cd62f39.tar.gz
use correct bin paths
Signed-off-by: steadfasterX <steadfasterX@gmail.com>
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8b9bf0c87561..d20e8f7b5d00 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -46,16 +46,16 @@ package(){
cp -a $pkgname-$pkgver/build/image/easy-installer-linux-x64 $pkgdir/opt/${pkgname}
cat > $pkgdir/$BINFIX/${pkgname} << _EOB
#!/bin/bash
-
-cd /opt/${pkgname}/bin
-./easy-installer
+####################################
+# the binary itself gets its working directory path from
+# $0 so a symlink wouldn't work
+/opt/${pkgname}/bin/easy-installer
_EOB
chmod 755 $pkgdir/$BINFIX/${pkgname}
-
cat > $pkgdir/usr/share/applications/e.foundation.${pkgname}.desktop << _EOD
[Desktop Entry]
Name=Easy Installer for /e/
-Exec=${pkgname}
+Exec=/opt/${pkgname}/bin/${pkgname}
Icon=/opt/${pkgname}/${pkgname}.png
Terminal=false
Type=Application