summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTomasz Zok2020-10-07 10:50:08 +0200
committerTomasz Zok2020-10-07 10:50:08 +0200
commit6da906d41edcae28bbba2ca68c0a0b91d43b65c4 (patch)
treee72d56d1cd5c68a474b34d0ec6ef0171668e5282
downloadaur-6da906d41edcae28bbba2ca68c0a0b91d43b65c4.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fc32cc503a19
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = easy-pandoc-templates-git
+ pkgdesc = A collection of portable pandoc templates with no dependencies
+ pkgver = r52.6d9c95a
+ pkgrel = 1
+ url = https://github.com/ryangrose/easy-pandoc-templates
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = pandoc
+ provides = easy-pandoc-templates
+ conflicts = easy-pandoc-templates
+ source = git+https://github.com/ryangrose/easy-pandoc-templates.git
+ md5sums = SKIP
+
+pkgname = easy-pandoc-templates-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d58dd7138326
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Tomasz Zok <tomasz.zok [at] gmail.com>
+pkgname=easy-pandoc-templates-git
+pkgver=r52.6d9c95a
+pkgrel=1
+pkgdesc="A collection of portable pandoc templates with no dependencies"
+arch=(any)
+url="https://github.com/ryangrose/easy-pandoc-templates"
+license=('GPL')
+depends=('pandoc')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('git+https://github.com/ryangrose/easy-pandoc-templates.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ install -d "$pkgdir/usr/share/pandoc/data/templates"
+ install -t "$pkgdir/usr/share/pandoc/data/templates" html/*
+}