aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwszqkzqk2022-07-20 19:19:39 +0800
committerwszqkzqk2022-07-20 19:19:39 +0800
commitd6383006e25da939f88150917d9e0395dd98734b (patch)
treed526231973e7c3b2fde4f7bc4e57a730fd2d031b
parenta7a71bbfc8ba8bac3dc073b88127cd2f542587e6 (diff)
downloadaur-d6383006e25da939f88150917d9e0395dd98734b.tar.gz
Updated by update.sh
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rwxr-xr-xeasy-zsh-config29
3 files changed, 21 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c5949294b04a..3dc79706fae7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = easy-zsh-config
pkgdesc = A simple but fast and out of the box configuration of zsh powered by oh-my-posh and zsh pulgins.
- pkgver = 0.5.0
- pkgrel = 3
+ pkgver = 0.5.1
+ pkgrel = 1
url = https://github.com/wszqkzqk/easy-zsh-config
install = easy-zsh-config.install
arch = any
@@ -22,6 +22,6 @@ pkgbase = easy-zsh-config
source = easy-zsh-config
sha256sums = 7395fad38d918d699763f53bbc75764d9318e755591099fc625b3e5f23ed4d94
sha256sums = 191f93567e767c599cfd843bb8343f311396d8e80d423ec38af2ad3dc52551a3
- sha256sums = d8063c962f9f3e0f97315cd20403dabaa0644355be09131cd09b862c88962639
+ sha256sums = 080339f03c71f432c0aea60025c3fb355d613cba5d155708bb480a611fb7d713
pkgname = easy-zsh-config
diff --git a/PKGBUILD b/PKGBUILD
index 978bde6a7015..6f69f127c1d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: wszqkzqk <wszqkzqk@qq.com>
pkgname=easy-zsh-config
- pkgver=0.5.0
- pkgrel=3
+ pkgver=0.5.1
+ pkgrel=1
pkgdesc="A simple but fast and out of the box configuration of zsh powered by oh-my-posh and zsh pulgins."
arch=(any)
url=https://github.com/wszqkzqk/easy-zsh-config
@@ -25,7 +25,7 @@ source=("zshrc"
"easy-zsh-config")
sha256sums=('7395fad38d918d699763f53bbc75764d9318e755591099fc625b3e5f23ed4d94'
'191f93567e767c599cfd843bb8343f311396d8e80d423ec38af2ad3dc52551a3'
- 'd8063c962f9f3e0f97315cd20403dabaa0644355be09131cd09b862c88962639')
+ '080339f03c71f432c0aea60025c3fb355d613cba5d155708bb480a611fb7d713')
package(){
install -Dm644 zshrc "${pkgdir}/etc/skel/.zshrc"
diff --git a/easy-zsh-config b/easy-zsh-config
index 78644fae5251..928061cb0dda 100755
--- a/easy-zsh-config
+++ b/easy-zsh-config
@@ -1,25 +1,26 @@
## Config the theme file from arg. or use fallback theme file
if [ $# -gt 0 ]; then
- if [[ -r "${1}" ]]; then
- _POSH_THEME="${1}"
- else
- _POSH_THEME="/usr/share/oh-my-posh/themes/jandedobbeleer.omp.json"
- fi
-else
+ if [[ -r "${1}" ]]; then
+ _POSH_THEME="${1}"
+ else
_POSH_THEME="/usr/share/oh-my-posh/themes/jandedobbeleer.omp.json"
+ fi
+else
+ _POSH_THEME="/usr/share/oh-my-posh/themes/jandedobbeleer.omp.json"
fi
## Apply the theme file
if [[ -r "${_POSH_THEME}" ]]; then
- eval "$(oh-my-posh init zsh --config \"${_POSH_THEME}\")"
+ ${POSH_THEME}=${_POSH_THEME}
+ eval "$(oh-my-posh init zsh)"
else
- echo "Warning: \"${_POSH_THEME}\" is unreachable!"
- echo "Oh My Posh theme is disabled! Using the fallback \"elite2\" theme now!"
- echo "Please check your theme file's existance and read permission!"
- echo "Tips: run \"sudo chmod +r -R /usr/share/oh-my-posh/\" may helps when there're permission issues."
- autoload -U promptinit
- promptinit
- prompt elite2 green yellow
+ echo "Warning: \"${_POSH_THEME}\" is unreachable!"
+ echo "Oh My Posh theme is disabled! Using the fallback \"elite2\" theme now!"
+ echo "Please check your theme file's existance and read permission!"
+ echo "Tips: run \"sudo chmod +r -R /usr/share/oh-my-posh/\" may helps when there're permission issues."
+ autoload -U promptinit
+ promptinit
+ prompt elite2 green yellow
fi