aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwszqkzqk2022-12-20 00:13:28 +0800
committerwszqkzqk2022-12-20 00:13:28 +0800
commitfd125818fc0b194a8427db34533df7cd909761f3 (patch)
tree9e8da0b6cfcd8e0674913dab5ebb39f36b925723
parent3ab57ec2f410d4a69f8c9433970ba84e339bea82 (diff)
downloadaur-fd125818fc0b194a8427db34533df7cd909761f3.tar.gz
Updated by update.sh
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD36
-rwxr-xr-xeasy-zsh-config4
3 files changed, 22 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d25c14a1beb2..3da4d2dfe8ec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = easy-zsh-config
pkgdesc = A simple but fast and out of the box configuration of zsh powered by oh-my-posh and zsh pulgins.
pkgver = 0.5.9
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/wszqkzqk/easy-zsh-config
install = easy-zsh-config.install
arch = any
@@ -22,6 +22,6 @@ pkgbase = easy-zsh-config
source = easy-zsh-config
sha256sums = b647be9ef5fd3eb1e6587dbccaedeff2bf298c13e568ddfd4c436fadb8e9061f
sha256sums = 191f93567e767c599cfd843bb8343f311396d8e80d423ec38af2ad3dc52551a3
- sha256sums = ba90b9b278a455759407eab6d74a1541f8351f17d591846aaa5a5f8c5eb81ed9
+ sha256sums = 15453024eebe8a367cd5feb85aab1df9ec82bd026c25041b76930d8ad5b9c8b4
pkgname = easy-zsh-config
diff --git a/PKGBUILD b/PKGBUILD
index 038a49b5e049..e0ceccaf109f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,21 @@
- # Maintainer: wszqkzqk <wszqkzqk@qq.com>
+# Maintainer: wszqkzqk <wszqkzqk@qq.com>
- pkgname=easy-zsh-config
- pkgver=0.5.9
- pkgrel=3
- pkgdesc="A simple but fast and out of the box configuration of zsh powered by oh-my-posh and zsh pulgins."
- arch=(any)
- url=https://github.com/wszqkzqk/easy-zsh-config
- license=("MIT")
- conflicts=("grml-zsh-config"
- "manjaro-zsh-config")
- depends=( "zsh"
- "oh-my-posh"
- "zsh-syntax-highlighting"
- "zsh-autosuggestions"
- "zsh-history-substring-search"
- "ttf-hack-nerd"
- )
+pkgname=easy-zsh-config
+pkgver=0.5.9
+pkgrel=4
+pkgdesc="A simple but fast and out of the box configuration of zsh powered by oh-my-posh and zsh pulgins."
+arch=(any)
+url=https://github.com/wszqkzqk/easy-zsh-config
+license=("MIT")
+conflicts=("grml-zsh-config"
+ "manjaro-zsh-config")
+depends=("zsh"
+ "oh-my-posh"
+ "zsh-syntax-highlighting"
+ "zsh-autosuggestions"
+ "zsh-history-substring-search"
+ "ttf-hack-nerd"
+ )
optdepends=("pkgfile: to provide a function that will automatically search the pkgfile database when entering an unrecognized command")
backup=("root/.zshrc"
"etc/skel/.zshrc")
@@ -25,7 +25,7 @@ source=("zshrc"
"easy-zsh-config")
sha256sums=('b647be9ef5fd3eb1e6587dbccaedeff2bf298c13e568ddfd4c436fadb8e9061f'
'191f93567e767c599cfd843bb8343f311396d8e80d423ec38af2ad3dc52551a3'
- 'ba90b9b278a455759407eab6d74a1541f8351f17d591846aaa5a5f8c5eb81ed9')
+ '15453024eebe8a367cd5feb85aab1df9ec82bd026c25041b76930d8ad5b9c8b4')
package(){
install -Dm644 zshrc "${pkgdir}/etc/skel/.zshrc"
diff --git a/easy-zsh-config b/easy-zsh-config
index 1627fe0fd701..b8b436b65325 100755
--- a/easy-zsh-config
+++ b/easy-zsh-config
@@ -26,8 +26,8 @@ fi
## Set history
HISTFILE=~/.zsh_history
-HISTSIZE=10000
-SAVEHIST=10000
+HISTSIZE=100000
+SAVEHIST=100000
setopt correct # Auto correct mistakes
setopt extendedglob # Extended globbing. Allows using regular expressions with *
setopt nocaseglob # Case insensitive globbing