summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Riedesel2017-10-14 09:45:16 -0500
committerMark Riedesel2017-10-14 09:45:16 -0500
commita9662e87e1f74d2c29dc266fcf18acfa5be574a6 (patch)
tree25959365de164c4b40dd0f1968f6e8b0ae454bec
downloadaur-a9662e87e1f74d2c29dc266fcf18acfa5be574a6.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b681fc80b56c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = easy_profiler
+ pkgdesc = Lightweight cross-platform profiler library for c++
+ pkgver = 1.3.0
+ pkgrel = 0
+ url = https://github.com/yse/easy_profiler
+ arch = x86_64
+ arch = i686
+ arch = arm
+ license = MIT
+ makedepends = cmake
+ source = easy_profiler-1.3.0.tar.gz::https://github.com/yse/easy_profiler/archive/v1.3.0.tar.gz
+ md5sums = 07b0c1a666c905c2894dbd323ed6efe7
+
+pkgname = easy_profiler
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3dd72e3a61db
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+#Maintainer: Mark Riedesel <mark@klowner.com>
+
+pkgname=easy_profiler
+pkgver=1.3.0
+pkgrel=0
+pkgdesc='Lightweight cross-platform profiler library for c++'
+arch=('x86_64' 'i686' 'arm')
+url='https://github.com/yse/easy_profiler'
+license=('MIT')
+makedepends=('cmake')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/yse/${pkgname}/archive/v${pkgver}.tar.gz")
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ mkdir -p build
+ cd build
+ cmake .. -DCMAKE_BUILD_TYPE="Release" \
+ -DCMAKE_INSTALL_PREFIX=/usr
+
+ make
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}/build
+ make DESTDIR=${pkgdir} install
+ mv ${pkgdir}/usr/bin/*.so ${pkgdir}/usr/lib/
+}
+
+md5sums=('07b0c1a666c905c2894dbd323ed6efe7')