summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Riedesel2019-12-11 06:52:32 -0600
committerMark Riedesel2019-12-11 06:52:32 -0600
commitae4e1adb3d7d7308b7d46144e3d45f9f43182d39 (patch)
tree70f5da4611e19b253ce81ceb311cb592972cef06
parentfca90049607f6f0df5ae2a7ffe77d53ef80349ff (diff)
downloadaur-ae4e1adb3d7d7308b7d46144e3d45f9f43182d39.tar.gz
update to 2.1.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
-rw-r--r--cmake-destination.patch15
-rw-r--r--cmake-license-destination.patch11
4 files changed, 23 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5bccb54889aa..2ba8d198dd97 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = easy_profiler
pkgdesc = Lightweight cross-platform profiler library for c++
- pkgver = 2.0.1
+ pkgver = 2.1.0
pkgrel = 1
url = https://github.com/yse/easy_profiler
arch = x86_64
@@ -8,10 +8,10 @@ pkgbase = easy_profiler
arch = arm
license = MIT
makedepends = cmake
- source = easy_profiler-2.0.1.tar.gz::https://github.com/yse/easy_profiler/archive/v2.0.1.tar.gz
- source = cmake-destination.patch
- md5sums = f5d17cd937ba39d3b2584b003a71e6a7
- md5sums = 2e3f68c068787b71c2746b237550036d
+ source = easy_profiler-2.1.0.tar.gz::https://github.com/yse/easy_profiler/archive/v2.1.0.tar.gz
+ source = cmake-license-destination.patch
+ md5sums = 11cf4ffdfcec905752aa820bea27648a
+ md5sums = 6f251eca4ba10416dfb70c639baac4d7
pkgname = easy_profiler
diff --git a/PKGBUILD b/PKGBUILD
index b088b7fc69c7..7bcc1dbbbf32 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
#Maintainer: Mark Riedesel <mark@klowner.com>
pkgname=easy_profiler
-pkgver=2.0.1
+pkgver=2.1.0
pkgrel=1
pkgdesc='Lightweight cross-platform profiler library for c++'
arch=('x86_64' 'i686' 'arm')
@@ -10,12 +10,12 @@ license=('MIT')
makedepends=('cmake')
source=(
"${pkgname}-${pkgver}.tar.gz::https://github.com/yse/${pkgname}/archive/v${pkgver}.tar.gz"
- cmake-destination.patch
+ cmake-license-destination.patch
)
prepare() {
cd ${pkgname}-${pkgver}
- patch -Np1 -i "${srcdir}/cmake-destination.patch"
+ patch -Np1 -i "${srcdir}/cmake-license-destination.patch"
}
build() {
@@ -33,5 +33,7 @@ package() {
make DESTDIR=${pkgdir} install
}
-md5sums=('f5d17cd937ba39d3b2584b003a71e6a7'
- '2e3f68c068787b71c2746b237550036d')
+md5sums=('11cf4ffdfcec905752aa820bea27648a'
+ '2e1aac0c28163fca3d44dc9598e48112')
+md5sums=('11cf4ffdfcec905752aa820bea27648a'
+ '6f251eca4ba10416dfb70c639baac4d7')
diff --git a/cmake-destination.patch b/cmake-destination.patch
deleted file mode 100644
index 8793d8b9e923..000000000000
--- a/cmake-destination.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff --git a/easy_profiler_core/CMakeLists.txt b/easy_profiler_core/CMakeLists.txt
-index 7d5bec4..4cfafde 100644
---- a/easy_profiler_core/CMakeLists.txt
-+++ b/easy_profiler_core/CMakeLists.txt
-@@ -306,8 +306,9 @@ install(
- easy_profiler
- EXPORT
- ${targets_export_name}
-- DESTINATION
-- bin
-+ LIBRARY DESTINATION lib
-+ ARCHIVE DESTINATION lib
-+ RUNTIME DESTINATION bin
- INCLUDES DESTINATION "${include_install_dir}"
- )
diff --git a/cmake-license-destination.patch b/cmake-license-destination.patch
new file mode 100644
index 000000000000..329da559244b
--- /dev/null
+++ b/cmake-license-destination.patch
@@ -0,0 +1,11 @@
+--- a/easy_profiler_core/CMakeLists.txt
++++ b/easy_profiler_core/CMakeLists.txt
+@@ -309,7 +309,7 @@
+ LICENSE.MIT
+ LICENSE.APACHE
+ DESTINATION
+- .
++ share/licenses/easy_profiler/
+ )
+
+ install(