summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Riedesel2018-10-17 20:05:27 -0700
committerMark Riedesel2018-10-17 20:05:27 -0700
commitfca90049607f6f0df5ae2a7ffe77d53ef80349ff (patch)
tree4118617c1019c26493a6e9ca680a1d73e7f8de21
parentabff58f00f1d52cdb880d04fdd1a872d965d445a (diff)
downloadaur-fca90049607f6f0df5ae2a7ffe77d53ef80349ff.tar.gz
Properly use CMake rather than move libs like a silly person
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD20
-rw-r--r--cmake-destination.patch15
3 files changed, 32 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0f44a67453d8..5bccb54889aa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = easy_profiler
pkgdesc = Lightweight cross-platform profiler library for c++
pkgver = 2.0.1
- pkgrel = 0
+ pkgrel = 1
url = https://github.com/yse/easy_profiler
arch = x86_64
arch = i686
@@ -9,7 +9,9 @@ pkgbase = easy_profiler
license = MIT
makedepends = cmake
source = easy_profiler-2.0.1.tar.gz::https://github.com/yse/easy_profiler/archive/v2.0.1.tar.gz
+ source = cmake-destination.patch
md5sums = f5d17cd937ba39d3b2584b003a71e6a7
+ md5sums = 2e3f68c068787b71c2746b237550036d
pkgname = easy_profiler
diff --git a/PKGBUILD b/PKGBUILD
index 06c500d079cd..b088b7fc69c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,28 +2,36 @@
pkgname=easy_profiler
pkgver=2.0.1
-pkgrel=0
+pkgrel=1
pkgdesc='Lightweight cross-platform profiler library for c++'
arch=('x86_64' 'i686' 'arm')
url='https://github.com/yse/easy_profiler'
license=('MIT')
makedepends=('cmake')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/yse/${pkgname}/archive/v${pkgver}.tar.gz")
+source=(
+ "${pkgname}-${pkgver}.tar.gz::https://github.com/yse/${pkgname}/archive/v${pkgver}.tar.gz"
+ cmake-destination.patch
+)
+
+prepare() {
+ cd ${pkgname}-${pkgver}
+ patch -Np1 -i "${srcdir}/cmake-destination.patch"
+}
build() {
cd ${srcdir}/${pkgname}-${pkgver}
mkdir -p build
cd build
- cmake .. -DCMAKE_BUILD_TYPE="Release" \
+ cmake .. \
+ -DCMAKE_BUILD_TYPE="Release" \
-DCMAKE_INSTALL_PREFIX=/usr
-
make
}
package() {
cd ${srcdir}/${pkgname}-${pkgver}/build
make DESTDIR=${pkgdir} install
- mv ${pkgdir}/usr/bin/*.so ${pkgdir}/usr/lib/
}
-md5sums=('f5d17cd937ba39d3b2584b003a71e6a7')
+md5sums=('f5d17cd937ba39d3b2584b003a71e6a7'
+ '2e3f68c068787b71c2746b237550036d')
diff --git a/cmake-destination.patch b/cmake-destination.patch
new file mode 100644
index 000000000000..8793d8b9e923
--- /dev/null
+++ b/cmake-destination.patch
@@ -0,0 +1,15 @@
+diff --git a/easy_profiler_core/CMakeLists.txt b/easy_profiler_core/CMakeLists.txt
+index 7d5bec4..4cfafde 100644
+--- a/easy_profiler_core/CMakeLists.txt
++++ b/easy_profiler_core/CMakeLists.txt
+@@ -306,8 +306,9 @@ install(
+ easy_profiler
+ EXPORT
+ ${targets_export_name}
+- DESTINATION
+- bin
++ LIBRARY DESTINATION lib
++ ARCHIVE DESTINATION lib
++ RUNTIME DESTINATION bin
+ INCLUDES DESTINATION "${include_install_dir}"
+ )