summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2020-01-11 22:13:37 +0100
committerNarrat2020-01-11 22:13:37 +0100
commit858a6c4120e7667d246a0dcb0496768d78d499c0 (patch)
tree7c7ef343c729b52692fb0e0f102ccb3546c3412c
parent6ce27dc82217bd5bde351dac6175ed00bfad42a9 (diff)
downloadaur-858a6c4120e7667d246a0dcb0496768d78d499c0.tar.gz
Update to 1.3.7.7
Change deps to python3 ones. Since 1.3.7.4 it is compatible with python3. As setup.py is not really working, leave the mess of installing this. Instead change the location to /opt until someone unfucks this.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD34
2 files changed, 26 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3674ae275eac..fc2f6a56e542 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Mon Dec 28 02:10:02 UTC 2015
pkgbase = easyabc
- pkgdesc = A graphical music notation editor for the ABC music notation language
- pkgver = 1.3.6.4.6
+ pkgdesc = graphical music notation editor for the ABC music notation language
+ pkgver = 1.3.7.7
pkgrel = 1
url = http://sourceforge.net/projects/easyabc/
arch = i686
@@ -10,14 +8,14 @@ pkgbase = easyabc
arch = ppc
license = GPL
makedepends = gendesk
- depends = wxpython2.8
- depends = python2-pyparsing
- depends = python2-pygame
+ depends = python-wxpython
+ depends = python-pyparsing
+ depends = python-pygame
depends = abcmidi
depends = abcm2ps
depends = ghostscript
- source = http://downloads.sourceforge.net/project/easyabc/EasyABC/1.3.6.4/easyabc_source_code_1.3.6.4.6.zip
- sha256sums = 1ce59298516ab970b43807b45693e1d940e8630167fb07c744cc993e0f8cbf23
+ source = http://downloads.sourceforge.net/project/easyabc/EasyABC/1.3.7.7/easyabc_source_code_1.3.7.7.zip
+ sha256sums = 98e775cc196254cdd7f4c07c0426ba713b159b48e8628b52345480d84301d928
pkgname = easyabc
diff --git a/PKGBUILD b/PKGBUILD
index 47ef94a6ae37..7362fc5637f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,17 @@
-# Maintainer: Simon Thorpe <simon@hivetechnology.com.au>
+# Contributor: Lex Black <autumn-wind@web.de>
+# Contributor: Simon Thorpe <simon@hivetechnology.com.au>
+
pkgname=easyabc
-pkgver=1.3.6.4.6
+pkgver=1.3.7.7
pkgrel=1
-pkgdesc="A graphical music notation editor for the ABC music notation language"
+pkgdesc="graphical music notation editor for the ABC music notation language"
arch=('i686' 'x86_64' 'ppc')
url="http://sourceforge.net/projects/easyabc/"
license=('GPL')
-depends=('wxpython2.8' 'python2-pyparsing' 'python2-pygame' 'abcmidi' 'abcm2ps' 'ghostscript')
+depends=('python-wxpython' 'python-pyparsing' 'python-pygame' 'abcmidi' 'abcm2ps' 'ghostscript')
makedepends=('gendesk')
-source=('http://downloads.sourceforge.net/project/easyabc/EasyABC/1.3.6.4/easyabc_source_code_1.3.6.4.6.zip')
-sha256sums=('1ce59298516ab970b43807b45693e1d940e8630167fb07c744cc993e0f8cbf23')
+source=(http://downloads.sourceforge.net/project/easyabc/EasyABC/${pkgver}/${pkgname}_source_code_${pkgver}.zip)
+sha256sums=('98e775cc196254cdd7f4c07c0426ba713b159b48e8628b52345480d84301d928')
prepare(){
gendesk -n --pkgname "$pkgname" --pkgdesc "$pkgdesc" \
@@ -19,15 +21,17 @@ prepare(){
}
package(){
- mkdir -p $pkgdir/usr/share
- mkdir -p $pkgdir/usr/bin
- cp -R $srcdir/easyabc_source_code_1.3.6.4.6 $pkgdir/usr/share/easyabc
- echo -e '#!/bin/bash\npython2 /usr/share/easyabc/easy_abc.py "$@"' >$pkgdir/usr/bin/easyabc
+ mkdir -p "$pkgdir"/usr/share
+ mkdir -p "$pkgdir"/usr/bin
+ mkdir -p "$pkgdir"/opt
+
+ cp -dpr --no-preserve=ownership "${pkgname}_source_code_${pkgver}" $pkgdir/opt/easyabc
+ echo -e '#!/bin/bash\npython /opt/easyabc/easy_abc.py "$@"' > $pkgdir/usr/bin/easyabc
chmod +x $pkgdir/usr/bin/easyabc
- install -Dm644 "$srcdir/easyabc_source_code_1.3.6.4.6/img/logo64.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
+ install -Dm644 "${pkgname}_source_code_${pkgver}/img/logo64.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
install -Dm644 "$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
-
- ln -s /usr/bin/abc2abc $pkgdir/usr/share/easyabc/bin/
- ln -s /usr/bin/abc2midi $pkgdir/usr/share/easyabc/bin/
- ln -s /usr/bin/abcm2ps $pkgdir/usr/share/easyabc/bin/
+
+ ln -s /usr/bin/abc2abc $pkgdir/opt/easyabc/bin/
+ ln -s /usr/bin/abc2midi $pkgdir/opt/easyabc/bin/
+ ln -s /usr/bin/abcm2ps $pkgdir/opt/easyabc/bin/
}